Bind: Namensauflösung der internen Zone funktioniert nicht



  • Hallo,

    ich habe Pfsense in der aktuellsten Version installiert und möchte, dass die Clients "test.test.intra" auflösen. Folgendermaßen bin ich vorgegangen:
    Bind installiert
    DNS Forwarder und DNS Resolver (standardmäßig in Pfsense) nicht aktiviert
    DHCP Einstellungen angepasst
    Bind aktiviert (kein Forwarder eingestellt)
    keine ACLs oder Views eingerichtet
    Zone "test.intra" erstellt, Zone Type: Master, Name Server der Zone 127.0.0.1, allow-query: any Den Rest habe ich nicht konfiguriert (Base Domain IP, Reverse Zone)
    A-Eintrag "test" hinzugefügt mit einer IP "192.168.1.2"

    Der Namensserver löst alle externen Namen richtig auf. Bei "nslookup test.test.intra" schreibt der Client "Non-Existent domain".

    Irgendwo habe ich einen Fehler gemacht.
    Leider finde auch keine vernünftige Anleitung.

    Vielen Dank.


  • LAYER 8 Moderator

    Name Server der Zone 127.0.0.1

    Sollte der Name der Zone nicht eher test.intra sein?



  • Danke für den Hinweis. Habs geändert, leider ohne Erfolg.

    Anbei noch Screenshots meiner Einstellungen.















  • LAYER 8 Moderator

    Ahoi,

    also was ich ändern würde:

    Name Server: interne IP der pfSense nutzen 192.168.1.1(?), nicht localhost (127.0.0.1)
    Base Domain IP: auf was Sinnvolles setzen (wenn du bspw. www.test.intra hast, würde ich darauf die Base Domain setzen, ansonsten ggf. auch die IP der pfSense selbst - muss aber nicht)
    Mail Admin Zone: Mailadresse intern für Fehler

    Zusätzlich solltest du einen Eintrag für 192.168.1.1 eintragen. Bspw. dns01.test.intra oder pfsense.test.intra oder wie auch immer deine Namenskonventionen aussehen. Zudem solltest du ebenfalls eine Pointer Zone für 192.168.1.x anlegen (PTR) und dort die .1 ebenfalls auf diesen Namen eintragen.

    Bspw.:

    rtr01 IN A 192.168.1.1 (steht für router 1, alternativ dns01, fwl01 o.ä.)

    und in der 1.168.192.in-addr.arpa Zone:

    1 IN PTR rtr01.test.intra.

    Grund sieht man in deinen Screenshots: der DNS weiß selbst von sich nicht, wer er ist (meldet auf 192.168.1.1 an den Client keinen Namen -> Unknown). Das sollte bei DNS nicht der Fall sein.

    Eine andere Alternative zu dem ganzen Aufwand wäre auch - sofern du nicht so sehr viele Einträge hast, die in den DNS müssen - einfach den DNS Forwarder oder den Resolver zu nutzen und dort zusätzliche Einträge hinzuzufügen. Diese können dann auch auf beliebige Namen auflösen und mit den Advanced Options kannst du auch eine kleine interne DNS Zone definieren (bspw. test.infra ist local, alle DHCP Clients automatisch dort dynamisch registrieren und alle festen Mappings aus dem DHCP und alle zusätzlichen Einträge aus dem Forwarder automatisch auflösen). Damit bist du zwar nicht ganz so flexibel wie mit einem ganzen DNS Server, aber wenn du keine Einträge mit SRV, TXT und Co. machen musst/willst und nur ein paar Clients/Server intern in eine eigene interne Zone packen willst, genügt das auch.

    Grüße
    Jens



  • vielen Dank.
    Einfach den Host-Eintrag unter "DNS-Resolver" hinzufügen hat geholfen.


  • LAYER 8 Moderator

    Du hast jetzt aber nicht den Resolver UND Bind gleichzeit laufen? ;)



  • Nein  :)
    Aber danke fürs mitdenken und deiner hilfe


Log in to reply