Squidguard stops from running after upgrading to 2.2



  • Does anyone here experience an issue on squidguard after upgrading to 2.2? Prior to upgrade, I'm using squid2 and squidguard. After upgrading to 2.2, I found out that squid2 is not running. I remove squid2 and install squid3. Now, squid is running fine but I could not get squidguard running. I tried to run squidGuard manually on the command line but after a couple of hours, it stops from running. No error found on the squidGuard logs.

    Anyone here experience the same?

    $ tail /var/squidGuard/log/squidGuard.log
    2015-03-23 09:38:06 [126] squidGuard stopped (1427074686.933)
    2015-03-23 20:08:49 [1873] squidGuard 1.4 started (1427112529.401)
    2015-03-23 20:08:49 [1873] squidGuard ready for requests (1427112529.404)
    2015-03-23 20:17:35 [1873] squidGuard stopped (1427113055.073)
    2015-03-24 00:00:01 [62424] squidGuard 1.4 started (1427126401.055)
    2015-03-24 00:00:01 [62424] squidGuard ready for requests (1427126401.113)
    2015-03-24 02:00:00 [62424] squidGuard stopped (1427133600.778)
    2015-03-24 04:20:16 [7368] squidGuard 1.4 started (1427142015.754)
    2015-03-24 04:20:16 [7368] db update done
    2015-03-24 04:20:16 [7368] squidGuard stopped (1427142016.219)
    
    $ tail -20 /var/log/system.log
    Mar  6 16:25:47 fw lighttpd[38477]: (connections.c.137) (warning) close: 82 Connection reset by peer 
    Mar  6 16:26:53 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 
    Mar  6 16:26:53 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 
    Mar  6 16:29:02 fw lighttpd[38477]: (connections.c.137) (warning) close: 17 Connection reset by peer 
    Mar  6 16:31:24 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 
    Mar  6 16:31:24 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 
    Mar  6 16:31:27 fw lighttpd[38477]: (connections.c.137) (warning) close: 372 Connection reset by peer 
    Mar  6 16:32:59 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol 
    Mar  6 16:33:14 fw lighttpd[38477]: (connections.c.137) (warning) close: 18 Connection reset by peer 
    Mar  6 16:40:34 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol 
    Mar  6 16:41:02 fw lighttpd[38477]: (connections.c.277) SSL: -1 5 54 Connection reset by peer 
    Mar  6 16:41:16 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol 
    Mar  6 16:42:38 fw lighttpd[38477]: (connections.c.137) (warning) close: 319 Connection reset by peer 
    Mar  6 16:42:46 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol 
    Mar  6 16:46:23 fw lighttpd[38477]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 
    Mar  6 16:46:51 fw lighttpd[38477]: (connections.c.137) (warning) close: 13 Connection reset by peer 
    Mar  6 16:49:15 fw lighttpd[38477]: (connections.c.137) (warning) close: 17 Connection reset by peer 
    Mar  6 16:54:59 fw lighttpd[38477]: (connections.c.137) (warning) close: 304 Connection reset by peer 
    Mar  6 16:55:22 fw lighttpd[38477]: (connections.c.137) (warning) close: 13 Connection reset by peer 
    


  • New SquidGuard apparently doesn't always stay running unless there is work for it to do.  Have you actually tried testing its functionality?


Log in to reply