Ath0: stuck beacon; resetting (bmiss count 4) ? ? ?



  • Hi Guys,

    In my system log  can see the following.

    ath0: stuck beacon; resetting (bmiss count 4)

    can anyone help? why is this happening


  • Banned

    What pfSense version?



  • im using 2.2.1 stable x64


  • Banned

    Nothing to do. Live with it or get an AP.



  • Try moving the wifi network to a different band or channel to see if it helps. Also you may need to adjust the default regulatory setting to your country in wireless settings. I also see this error on channel changes. So it depends on the frequency of your error.

    Upstream FreeBSD had problems with this error for years. It seems it is finally worked out. I am surprised to hear your having this problem. Does it seem to effect your ability to use the wifi network? What module are you using.



  • This used to be an actual problem for me under pfSense 2.1.x (based on FreeBSD 8.3).  At times, those errors would be a constant stream which all but ruined the logs and certainly ruined the connectivity on my Atheros interface.  I did a bout of debugging with the developer of the ath4 driver and, after helping me build several kernels with patched code without much improvement, he expressed that the real changes that finally fixed the problem were in upstream FreeBSD 9 and 10.  That is what got me really waiting for pfSense 2.2!

    Now that I am running the current release, the stuck beacon problem is all but gone.  I do still see the messages in my logs but its at the rate of one every several hours.  Where my Atheros interface used to be all but useless, it's now my primary one and has finally shown me the value of 802.11n.  Since I recall that this problem stems from the level of wireless congestion in your area, if your interface is working well enough for you, I'd just ignore those messages.  Otherwise, your only option is probably to address the congestion in your area (i.e. better antenna, relocating AP, WiFi blocking paint on surrounding walls, etc…).

    R/
    wbedard



  • using ar9827.

    it works fine but keeps hanging usually i can use the wifi  uninterrupted for hole day, but at times it hangs and i have to restart the interface.

    I have tried changing channels etc and i have set the correct domain reg etc for UK.

    i guess i will have to wait untill freebsd drivers and base are updated for things to become stable.



  • So i assume you meant AR9287 unless you are back from the future.
    Are you using an half sized mini pci-e module like this:

    https://wikidevi.com/wiki/Atheros_AR5B97



  • I'm still getting this too. Sometimes not for a full day, sometimes > 5 times a second. Device is Atheros AR5BXB112 (full sized mini pci-e, AR9380 by Apple).

    I also get the "discard frame w/o leading ethernet header" on this chip.

    pfSense 2.2.1 x64.

    I've got three antennas plugged in to it but they're semi-obscured behind the pfSense monitor, pot plants etc.

    SOHO, <= 5 users.



  • I also have these errors. (stuck beacon and discard frame w/o leading ethernet header)
    My card is TP-LINK TL-WN881ND (WI1 chip1: Atheros AR9287)
    I am fresh on pfSense with:
    2.2.6-RELEASE (amd64)
    built on Mon Dec 21 14:50:08 CST 2015
    FreeBSD 10.1-RELEASE-p25
    running on HP DC7900 with C2Q9400/8GB DDR2/2xSATA HDD/NV GT7300/HP NC360T/TL-WN881ND

    On changing wireless channel pfSense crashes and reboots.
    After reboot new channel is always accepted but errors still persists.

    Is there a stable driver and way to change it without recompile pfSense installer and clean install?