[SOLVED] Can connect to my OpenVPN server and webconfig access but no internet



  • I just built this router and my knowledge is very limited. I want to be able to have internet access on my phone through my OpenVPN server when I'm at work or other public networks. The client connects fine and I can log in to the router but no internet.

    Also I have pfSense connected as a client to a commercial VPN provider (IF = OVPN).  My old router is used as a switch and WiFi with DHCP turned off.

    "OpenVPN clients and Internet Access
    If you simply want to NAT your OpenVPN clients to your WAN IP so they can access the Internet
    using the OpenVPN connection, rules should automatically allow this."

    What do I need to do in order to get internet access?

    dev ovpns2
    dev-type tun
    tun-ipv6
    dev-node /dev/tun2
    writepid /var/run/openvpn_server2.pid
    #user nobody
    #group nobody
    script-security 3
    daemon
    keepalive 10 60
    ping-timer-rem
    persist-tun
    persist-key
    proto udp
    cipher AES-256-CBC
    auth SHA256
    up /usr/local/sbin/ovpn-linkup
    down /usr/local/sbin/ovpn-linkdown
    client-connect /usr/local/sbin/openvpn.attributes.sh
    client-disconnect /usr/local/sbin/openvpn.attributes.sh
    local XXX.XX.XXX.XX 
    engine rdrand
    tls-server
    server 10.0.8.0 255.255.255.0
    client-config-dir /var/etc/openvpn-csc
    username-as-common-name
    auth-user-pass-verify "/usr/local/sbin/ovpn_auth_verify user 'Local Database' false server2" via-env
    tls-verify "/usr/local/sbin/ovpn_auth_verify tls 'www.abdfds.ciom' 1"
    lport 45000
    management /var/etc/openvpn/server2.sock unix
    max-clients 1
    push "route 172.16.1.1 255.255.255.0"
    push "dhcp-option DNS 172.16.1.1"
    push "redirect-gateway def1"
    ca /var/etc/openvpn/server2.ca
    cert /var/etc/openvpn/server2.cert
    key /var/etc/openvpn/server2.key
    dh /etc/dh-parameters.4096
    tls-auth /var/etc/openvpn/server2.tls-auth 0
    comp-lzo adaptive
    persist-remote-ip
    float

    ![FW LAN.png](/public/imported_attachments/1/FW LAN.png)
    ![FW LAN.png_thumb](/public/imported_attachments/1/FW LAN.png_thumb)
    ![FW MINVPN.png](/public/imported_attachments/1/FW MINVPN.png)
    ![FW MINVPN.png_thumb](/public/imported_attachments/1/FW MINVPN.png_thumb)
    ![FW OPENVPN.png](/public/imported_attachments/1/FW OPENVPN.png)
    ![FW OPENVPN.png_thumb](/public/imported_attachments/1/FW OPENVPN.png_thumb)
    ![FW OVPN.png](/public/imported_attachments/1/FW OVPN.png)
    ![FW OVPN.png_thumb](/public/imported_attachments/1/FW OVPN.png_thumb)
    ![FW WAN.png](/public/imported_attachments/1/FW WAN.png)
    ![FW WAN.png_thumb](/public/imported_attachments/1/FW WAN.png_thumb)





  • SOLVED


Log in to reply