[Solved] Can't browse Internet via OpenVPN, no problem accessing my LAN



  • Apologies since this has been asked before but I'm unable to browse the Internet through my OpenVPN connection. I can access my LAN (over OpenVPN) but can't browse the Internet. After searching this topic, I went back to my settings: Firewall–>NAT-->Outbound Tab and changed from "Automatic outbound NAT rule generation" to "Manual Outbound NAT rule generation (AON - Advanced Outbound NAT)" saved/applied my settings, restarted OpenVPN service and even tried rebooting pfSense and reconnecting via my Android "OpenVPN Connect" App.

    Still, I can't get to anything on the Internet just hosts on my own LAN. I'm on 2.2.1 Release and have a very Simple setup: Single WAN/LAN and mostly default settings other than DDNS (needed for OpenVPN) and added a manual WAN Rule to block private networks (RFC1918) instead of using the WebConfigurator checkbox to block Private ranges on the WAN Rules. Did this so that I could selectively filter my F/W logs by creating an additional rule to Not Log (and Block) a very annoying single IP address in a private network range with a constant DHCP offer packet. I'm mentioning this only because that's not exactly default but I can't imagine how this could be a problem vs. selecting the Block Private ranges checkbox instead. Back to my question... Do I need to manually add any additional Pass Rule besides the Auto created Rules after switching from Automatic Outbound NAT Rule Generation to Manual Outbound NAT Rule Generation? If so can you be specific about where and what the rule should be? No Proxy on my network or anything else besides what's mentioned. Thanks very much for any guidance on this!



  • Figured it out, went back in to OpenVPN settings and changed my DNS Servers to Goggle's Public DNS Servers 8.8.8.8 and 8.8.4.4 and restarted OpenVPN service just in case - Now working perfectly! So my initial DNS entry was my pfSense IP which had I thought about it, would have realized that won't work.


Log in to reply