PfSense internet does not work ( Need desperate help!! )



  • @KOM:

    No, I use for my WAN 192.168.2.99 and for my LAN 192.168.2.100

    You cannot have your WAN and LAN on the same subnet.  Assuming you're using a mask of 255.255.255.0 (also known as /24) then as grandrivers said you need to change your LAN IP to something outside that subnet.

    If I am at home I will try that. Thanks already for helping me.



  • Yes, It works! (I can acces the site with the LAN) But!!! If I go to network on my server it says: NETWORK 2: Limited.



  • What do you have for your current LAN settings on pfSense, and what do you have for network settings on your Windows server?



  • My current LAN settings on my pfSense are:

    GENERAL CONFIG

    Enable (V) Enable Interface
    Desc.          LAN
    IPv4 conf. type          Static IPv4
    MAC          –-----------------------------
    MTU          -------------------------------
    MSS          -------------------------------

    STATIC IPV4 CONFIG

    IPv4 Adress            192.168.1.1 /24
    IPv4 upstream gateway  (NONE)

    I dont Use IPv6

    PRIVATE NETWORKS

    ( ) Block Private Networks
    (V) Block Bogan Networks

    On my win server: I dont use any settings for ethernet.



  • And KOM, You are an GREAT helper!



  • OK, that wasn't quite what I was looking for but no matter.  FYI when we ask for WAN/LAN details, we want to know your IP address, netmask and gateway values.

    If I remember, Windows sees you attached to a different network than before.  Your new network is Network1 and the old one is Network2.  It's complaining that your old network is unstable.  You should either delete that network or just ignore its status.  I'm assuming that everything else is working fine?

    On my win server: I dont use any settings for ethernet.

    What do you mean?  You mean you have it set to the default of Obtain an IP address automatically? If you have DHCP enabled on LAN with pfSense, then your Windows server should have gotten a valid IP address and you wouldn't have had the problems you had at all.



  • Wait, Wait.
    So you just say: Go to ethernet settings and set up: Static ip 192.168.1.1



  • Go to ethernet settings and set up: Static ip 192.168.1.1

    NO!! That is the IP address of the pfSense LAN interface.  All IP addresses must be unique.  This is basic networking.  If you want to use static IP then set your Windows server IP address to 192.168.1.2.

    If you enable DHCP on pfSense LAN then you don't have to specify static IP addresses, but that is up to you.



  • Welp… Not getting ethernet anymore.
    I set up this:

    WAN: 192.168.2.99 /24
    LAN: 192.168.1.1 /24

    I have one and only direct connection with my server to the pfSense box. (the pfSense does have the WAN and the LAN connected)
    When I go to my browser and type 192.168.1.1:24 then I get the error: This Webpage Isn't available.
    Soo... What do I need to do?


  • Banned

    @Koenvuurens:

    When I go to my browser and type 192.168.1.1:24 then I get the error: This Webpage Isn't available.

    What? ??? Why are you pointing your browser to port 24? You do NOT type 24 into the browser, that is a netmask!  :o



  • whoops I said it wrong, No I dont type :24



  • OK, we have spent enough time hunting and guessing in the dark.  Please take and post the following screenshots:

    Interfaces - WAN
    Interfaces - LAN
    Firewall - Rules - LAN
    Your Windows Network IP4 Ethernet Properties

    If you are paranoid, scrub any public IP addresses in your shots.



  • Yes, but that is not the problem ! I cant acces the WebConfigurator. So I can make screenshots if you want but I cant acces it!!


  • LAYER 8 Global Moderator

    Dude can you ping pfsense lan IP from the computer your trying to access the web gui from?

    So can you ping 192.168.1.1 ?

    From you computer is static or dhcp?  Please post ipconfig /all – assuming your on windows?



  • Yes I can ping the pfsense box
    and the settings are in the attachment!



  • LAYER 8 Global Moderator

    then you should just be able to go http://192.168.1.1

    Unless your browser is using a proxy that should open, or redirect you to https://192.168.1.1 and the webgui.



  • Okey, got it working again.
    but still no ethernet through my pfSense
    Attachments are:

    Interfaces - WAN
    Interfaces - LAN
    Firewall - Rules - LAN
    Windows Network IP4 Ethernet Properties









  • LAYER 8 Global Moderator

    Well sure looks like ethernet is working to me if your connected to the gui..

    So you set static on your PC.. If you meant no internet on your pc, yeah you didn't set any dns.. So how would you expect your pc to lookup anything?



  • If you meant no internet on your pc, yeah you didn't set any dns.. So how would you expect your pc to lookup anything?

    err… sorry... I dont understand that!
    Would you like to explain that a liiiiiiiiiiiiiiiitle bit more?
    but I said already in the first post that I ask a lot of questions



  • Oh do I need to set the DNS to the pfSense box? maybe? …


  • LAYER 8 Global Moderator

    you said ethernet, ethernet is not the internet.. That is your local network connection, etc..  which is clearly working if you can access the pfsense webgui via IP address.

    Normally yes pfsense would dns for your network, but it can be anything you want.  But if your going to setup a static IP and you want that box to resolve say www.google.com then yeah needs dns.. your picture was NOTHING..  So no shit kind of hard to resolve www.google.com or www.pfsense.com or www.cnn.com, etc. etc..



  • Sorry about the ethernet/internet problem, I am dutch already I said…(my english is not very good)
    So... I can just put anything in the DNS box?


  • LAYER 8 Global Moderator

    you can put in anything you want that is a valid nameserver that will resolve what you want.. Putting in say 8.8.8.8 (googledns) isn't going to resolve any local stuff that pfsense would know about, etc.



  • So …? Do I need to put in the dns box 8.8.8.8 ?
    also I already tried that and still not getting internet


  • LAYER 8 Global Moderator

    So from the web gui, go to diag, dns lookup - can you look up www.google.com for example

    Go to diag, ping - can you ping 8.8.8.8 ?  See attached screenshots

    If you can not get to the internet, how are you posting this stuff?






  • I post these posts with my 2nd link to the internet, but want do put an better router inbetween it.
    See attachments.






  • but want do put an better router inbetween it.

    I mean an powerfuller router with 6 links( 1 WAN and 5 LAN) and a WIFI- card.



  • Can somebody help …?



  • could you maje a short summary ? just what is working and what is not and what do you want the end goal to be ?
    it will make it less complicated for us to understand what you project should look like ;)



  • change your WAN interface to DHCP

    [Capture WAN.JPG](/public/imported_attachments/1/Capture WAN.JPG)



  • Already… Thanks everyone!
    GOT IT WORKING!!!!
    The big help and the small help helped both.
    I lock this thread and hope to talk to you later!


Log in to reply