PfSense 2.2+squid3+squidGuard: Remove X-Forwarded-For from headers



  • Hello everyone,

    Am running pfSense on a VK-T40E (w SSD), setup firewall rules. After a few days I installed Squid+SquidGuard for filtering, works good for a week now.

    When I browse the internet I noticed that my local IP address (e.g. 192.168.1.111) is sent in the headers: 
    X-Forwarded-For 192.168.1.111

    E.g. surf to: http://www.xhaus.com/headers

    Question:
    I want to remove the X-Forwarded-For from the headers (increased privacy).
    Does anyone how to do this?

    Details:
    pfSense 2.2.1-RELEASE (amd64) built on Fri Mar 13 08:16:57 CDT 2015 FreeBSD 10.1-RELEASE-p6
    squid3 3.4.10_2 pkg 0.2.6
    squidGuard 1.4_7 pkg v.1.9.10

    Thanks,
    Peter



  • Services - Proxy server - Logging Settings - Disable X-Forward



  • Works, thank you! (set to: delete)



  • You probably want to click every box that looks like it might "stealth" a proxy.


Log in to reply