Squid3 won't start complains about acls, help viconf



  • Hello,

    My squid3 install will not start the service, it will complain of an issue with acl "allowed_subnets"

    when I check XML via console using 'viconfig' I see the following:

                    <squidnac><config><allowed_subnets>MC4wLjAuMC8w</allowed_subnets>
                                    <unrestricted_hosts><banned_hosts><whitelist><blacklist><block_user_agent><block_reply_mime_type><addtl_ports>1935 8134 7074</addtl_ports>
                                    <addtl_sslports>80 5222 8006 2096 2086 2087 2082
     2083 2096 53215 1935 8134</addtl_sslports></block_reply_mime_type></block_user_agent></blacklist></whitelist></banned_hosts></unrestricted_hosts></config></squidnac> 
    

    why is <allowed_subnets>MC4wLjAuMC8w</allowed_subnets> not a network? if its a definition where can I find or edit MC4wLjAuMC8w so I figure out what it is? because I can start squid if I manually edit squid.conf but then if I restart the service via pfsense GUI it will reset to the wrong configuration… I need to edit allowed_subnets to 0.0.0.0/0 so all networks can use proxy (all LAN networks I mean)

    here is the error in system log

    [b]php-fpm[90092]: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was '2015/03/31 18:28:30| ERROR: '0.0.0.0/0' needs to be replaced by the term 'all'. 2015/03/31 18:28:30| SECURITY NOTICE: Overriding config setting. Using 'all' instead. 2015/03/31 18:28:30| Warning: empty ACL: acl throttle_exts urlpath_regex -i "/var/squid/acl/throttle_exts.acl"[/b]
    

    the squid conf has this:

    Allow local network(s) on interface(s)

    acl localnet src  192.168.70.0/24 128.0.0.0/1.2197950726191

    dunno where 128.0.0.0/1.2197950726191 is coming from.



  • ok looks like the problem was an intervace without IP config was inadvertedly selected under proxy interfaces on squid config page. Seems to be working now (at least service starts) these errors/warnings remain:

    php-fpm[71851]: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was '2015/03/31 18:38:12| Warning: empty ACL: acl throttle_exts urlpath_regex -i "/var/squid/acl/throttle_exts.acl"'
    

    which came from "Cache Dynamic Content" being unselected while multiple options like "Windows Update" where selected below it… so enabling it again got rid of that warning above.

    hope it helps someone.


Log in to reply