Sudden and Unexplained PIA OpenVPN Trouble



  • Hello, all.

    I installed pfSense this evening and then followed the excellent guide on this site to get the PIA VPN working. Everything was running perfectly. Speeds were fantastic.

    I then went into the settings area for the OpenVPN client, and had a look around. I did not change anything, and I did not hit save. I simply returned back to the dashboard.

    Since that point, I have been completely unable to get the VPN to work. I have tried rebooting the server on several occasions. I have tried restarting the VPN service. Usually when I do restart the VPN service, it takes both the Unbound DNS Resolver and the NTP clock sync services down.

    Seriously at a loss as to what to try now. I didn't change anything, so this is some truly flaky behaviour. Note that as soon as I turn the OpenVPN service off, internet access is immediately restored to all my devices. Turn it back on, internet access is gone.

    Any suggestions appreciated.

    Thanks.

    Edit: By the way, I did confirm that the PIA server is not the issue, as I can connect to it via other means.



  • Tried everything I could think of last night to get it running again, including full re-installation and configuration, but nothing would work. Finally gave up and went to bed.

    This morning, I restarted all of my services, and it works again. While I'm glad to be up and running again, this sort of randomness and unpredictability is not reassuring. The VPN server was not down at the time, so I have no idea what was going on.



  • Has anyone experienced something similar with another VPN provider, or could this be a PIA issue?

    Also, since you have some experience with VPNs, how do you think PIA stacks up against other VPN providers?



  • May have been an issue with PIA.  Mine broke for about four hours a couple of days ago, never changed a thing.  Did a restore settings from a previous back up and rebooted, came right back up.


Log in to reply