PIA OpenVPN Gateway Offline



  • forgive the nubbie question as I am new to Pfsense.

    I have a Private Internet Access VPN setup which appears to be working. i.e., my internet address shows in the locale i selected for my PIA server and not as my ISP provided one, so that's working.

    Using Whatsmyip address is also showing the PIA IP address. in the Pfsense dashboard, the OPT interface attached to the  PIA OpenVPN shows up an running and shows a 10.xx.xx.xx address.

    i have two gateways showing up on the pfsense dashboard, PIA OpenVPN_VPN4, which shows the 10.xx.xx.xx same as the openvpn interface, and WAN under 50.xx.xx.xx. I have setup all firewall rules to use the PIA VPN gateway  and under routing i have checked the PIA OpenVPN gateway as default.

    However, in my dashboard the WAN gateways shows up online and running and the PIA openVPN gateway shows offline. I tried resetting the the pfsense box and but i cant seem to get this gateway to show online. Looking at the RSD graph, it appears that traffic is going up the WAN, as all traffic through the PIAVPN gateways shows up as 100% packet loss.

    Any ideas…



  • @L068904:

    fHowever, in my dashboard the WAN gateways shows up online and running and the PIA openVPN gateway shows offline. I tried resetting the the pfsense box and but i cant seem to get this gateway to show online. Looking at the RSD graph, it appears that traffic is going up the WAN, as all traffic through the PIAVPN gateways shows up as 100% packet loss.

    Any ideas…

    I think PIA blocked gateway pings so it always shows offline. Turn off gateway monitoring or specify a pingable IP in the routing –> Gateway screen.



  • Thanks Coolspot. Disabling monitoring the PIA gateway fixed it.  :)


Log in to reply