SquidGuard-squid3 not in GUI



  • Hi everyone , i have here an issue with my pfsense 2.2 that i am unable to fix it .

    I installed squidGuard-squid3 to apply some url filters  , and when i install the package everything is ok but it does not appear in Menu !!!

    squidGuard-squid3 installation completed.
    Loading package instructions…
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...done.
    Menu items... done.
    Integrated Tab items... done.
    Services... done.
    Writing configuration... done.

    Installation completed.  Please check to make sure that the package is configured from the respective menu then start the package.

    I have no idea how to fix this .

    I also try to install "squidGuard" , psense makes the download , starts the extraction and stays there forever !!!

    Installing squidGuard and its dependencies.
    Beginning package installation for squidGuard .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squidGuard and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/8/All/squidguard-1.4_4-i386.pbi ...  (extracting)

    when i go to installed packages i see both of them , but none of them are in the menu !!!

    i am lost .

    thanks for the patience .



  • Got this issue solved by removing all the packages , reboot the firewall and then install the package .
    It looks that my pfsense does not like to install multiple packages in one session , i had to reboot everytime i needed to install a new package .



  • 1.  Squidguard requires Squid.
    2.  You only need to install one instance of SquidGuard: the one that goes with your version of squid.

    You have three SquidGuards installed and no Squid.  No wonder it doesn't work.

    Here is what to do:

    1.  Install Squid3.
    2.  Install SquidGuard-squid3.


Log in to reply