Pfsense 2.2.1 Roku Media Player Strange Things Happening



  • Hi,

    I have a Pfsense 2.2.1 box that has WAN,LAN,WIFI and Bridge installed. I don't have any proxy servers installed yet.  Pretty simple setup.

    My Roku Media Player works for about 1 day then just stops with this message "No Media Devices Found"  I couldn't figure out what was wrong so I bypassed the Pfsense box and it worked. So I left it alone for about 2 weeks and it still didn't work. I ended up rebuilding the Pfsense box and guess what? The Roku Media Player worked until a day later then stopped working.

    I have the Universal Media Server in my house I'm connecting via DLNA

    I can ping the Roku from my PC and from the DLNA server. Netflix and everything else Works Perfect, Just the Media Player stops working. I have 3 Roku's in my house all work except for the Media Player.

    I have no more hair to pull out. Can someone please point me in the right direction?

    Thanks,
    Rick



  • Is all of this on one single subnet?  Just the LAN?



  • Yes all 1 subnet



  • In that case, that is abit odd.  Any weird firewall rules running?  On Pfsense or any machine?



  • Nope. Just basic install and setup. I will tell you this… I "Think" it stopped working when I went to 2.2 I know for a fact since 2.2.1 it stopped.



  • Could be an issue with your DNS setting I suppose, although I admit I can't imagine what settings would cause that.



  • Well why would it work for 1 day? If DNS was an issue it wouldn't work at all.  I thought about that too. lol



  • Because the new default DNS is unbound and there has been some issue with frequent restarts of unbound depending on settings….

    Not sure if that could cause issues for you.  I have no idea if this can create your situation.


  • LAYER 8 Netgate

    Duplicate IP somewhere or a DHCP lease expiring and not being renewed?

    When it is in a failed state can you ping/access it from the LAN?  How about the Media Devices?

    Does your ARP/IP match the MAC address of the device?

    Hard to know with the amount of information Roku gives.



  • Derelict - I wonder if assigning static leases in DHCP for everything involved might help?


  • LAYER 8 Netgate

    Shouldn't be changing and shouldn't matter.  Start at the bottom and work up…  Look at logs.



  • No dupe IP's and DHCP is working fine.  Just to add another note.  All my PS3's and Phone, Tablet can access the media server fine. It's just the Roku's that stopped accessing the Media Server, But like I said before Netflix, Amazon and everything else works fine.

    Yes I can ping it from here and the media server and the Roku is not working.


Log in to reply