Update von nanobsd (4g) 2.1.5 to 2.2.1, kein ovpn nach boot



  • hi leute
    Sorry falls ich hier gegen eine Regel verstoße weil ich habe mein Problem schon im englisch sprachigen Forum gestellt habe. Da ich dort aber leider keine Reaktion erhielt dachte ich probiere es noch hier.  :)
    Folgendes Problem: Ich habe zwei Igel 4210 LX für pfsense nanobsd laufen. Ich bin leider alles andere als ein netzwerk profi. Nach anleitungen im netz konnte ich den igel aber als ovpn tunnel für einen bezahl vpn service einrichten.  Ich habe von 2.1.5 nach 2.2.1 (nanobsd (4g)) upgedatet. Läuft an sich sehr gut nur leider habe ich seitdem folgendes Problem. Nach dem einschalten oder reboot bekomme ich keinen Internet Zugang. Laut Status Seite ist aber alles ok und grün. erst nach einem manuellen restart des ovpn clients habe ich normalen internet zugang. in den status meldungen des ovpn clients gibt es keinen error, aber es gibt eine Meldung von wegen "Device busy"? Hat vielleicht irgendwer einen Lösungsvorschlag? Danke im voraus für alle hilfreichen Antworten. :)



  • hi
    Habe weiter herumprobiert aber keine Lösung gefunden. Da der zweite Igel unbedingt automatisch laufen muss und ein manueller restart des ovpn client nicht machbar ist überlege ich auf 2.1.5 zurück zu wechseln. Weiß jemand wie "unsicher" diese Version inzwischen geworden ist? Auf der Box läuft nichts spezielles, einfach Firewall mit einem tunnel zum ovpn serivce.
    mfg
    Steve



  • hi
    Installiere Zusatzpaket Service Watchdog ,mit dem kannst du ausgefallene Dienste Auto-Starten.
    Hab es auch so laufen mit Open-VPN Dienst.
    Gruss Jap



  • hi jap
    watchdog? finde kein zusatzpaket mit diesem namen? was soll das sein?
    mfg
    steve

    edit:
    http://www.freebsd.org/cgi/man.cgi?query=watchdog <–---soll es das sein?



  • Hi
    Im Configurationsinterface  System –> Packages --> Available Packages dort ist Service Watchdog zu finden.
    Der genau das macht. (Monitors for stopped services and restarts them.)
    Ich hab aber eine full installation u keine nano vielleicht ist das der Grund , wobei bei nano auch zusatzpakete möglich sein sollten.
    Gruss Jap 8)



  • hi
    ja bei nano finde ich nichts. wobei muß das auch nicht von der hardware unterstützt werden? weil bei mir im bios gibt es keine watchdog funktion. fürchte das ist also keine möglichkeit für mich.



  • Hi!

    Habe eben auf meiner NanoBSD Installation nachgesehen, weil ich selbst Watchdog nicht verwende. Selbe Version, 2.2.1, hier gibt es das Paket "Service Watchdog" zur Auswahl.

    Mit der Hardware hat das nichts zu tun. Das ist nur ein weiterer Service, der auf der pfSense läuft.
    Die Sache im BIOS ist was anderes.



  • hi viragomann
    ja du hast recht. das problem ist bloß das der service ja gestartet wird und laut status seite läuft. er funktioniert nur nicht. aber vielleicht kann das watchdog paket auch einen restart durchführen? werde schauen ob ich darüber näheres erfahren kann. danke für den tip auf alle Fälle.
    Du hast keine Probleme auf deiner nanobsd installation mit ovpn?
    mfg
    steve



  • Hi,

    wie du geschrieben hast, funktioniert der VPN Client aber nach einem Restart des Dienstes. Das könnte Watchdog auch für dich automatisch erledigen. Also würde ich es versuchen, wenn du keine andere Lösung findest.

    Ich verwende selbst nur einen OpenVPN Server auf der NanoBSD, der läuft problemlos.

    Laut dem, was ich hier im Board gelesen habe, ist aber der Einsatz eines OVPN Clients doch weit verbreitet. Die einzelnen Probleme kenne ich aber nicht.



  • hi viragomann
    habe eben ausprobiert. leider scheint es so wie ich gedachte habe. da der service beim booten gestartet wird macht der service watchdog gar nichts. auch finde ich keinen weg den ovpn tunnel nicht automatisch zu starten. weil dann denke ich könnte ihn der watchdog nachträglich starten und vielleicht würde es funktionieren.
    gruß


Log in to reply