Can't get a WAN IP if direct but thru a router can.



  • Missing one little thing to get an external :  (pics of network attached)

    fresh install on fresh vmsphere 6
    dual intel nics VMX3 or E1000 (lan works)

    Doesn't Work IF:
    WAN cannot get external IP (dynamic)- if anything it picks up a internal ip.

    setup:
    LAN (HP procurve dumb switch) >PF (192.168.1.1)> modem (isp dhcp cable)
    No connectivity out

    WORKS IF:

    internal PCs (LAN (HP procurve dumb switch)>PF> then as client into DCHP serving tp-link router (192.168.1.1) that connects to modem> internet

    PF can ping, dl pkg's etc. it connects.

    its a go- just changed PF to 192.168.1.2

    I thought it may be VM giving trouble but no- its fine. also tried PF on bare metal and that works getting an external address. \

    tried:

    ifconfig em0 down
    ifconfig em0 up

    rebooting. SO nics work fine (vm'ed or not).

    Stuck. any advice.



    ![doesnt work.PNG](/public/imported_attachments/1/doesnt work.PNG)
    ![doesnt work.PNG_thumb](/public/imported_attachments/1/doesnt work.PNG_thumb)



  • Forgot to add:

    +stock rules that comes with
    +no wacky ISP
    +also tried; advanced>firewall/nat>disable firewall>Disable all packet filtering> checked
    +checked cables and used new ones even though old ones work.
    same result.



  • @d324vs:

    WAN cannot get external IP (dynamic)- if anything it picks up a internal ip.

    Then your ESX network config is wrong. WAN should be on the vswitch connected to the NIC going to the modem, with no other physical connections on that vswitch.


  • LAYER 8 Global Moderator

    So did you reboot your modem when you changed devices.. Cable modems like to cache the mac of the device connected to them - if you change that, like router to pfsense in a vm then reboot your modem.



  • (rebooted router all that easy stuff)

    EM0- wan
    EM1- lan

    on the esxi config I made the connection to it; 192.168.1.4 on the em1. (that  I have never changed)

    When hooked like the "does work" picture ESXI can ping external ip and DNS resolve. PF can also ping and resolve.

    Other than that- nothing has been done with the networking- its stock config on the esxi side.



  • As a test, try hooking up a computer to isp modem and see if you get an IP.



  • SOLVED!!!!! thanks CMB!!!

    (have 4 nics total on board, all intel i354- and I kept 1 for esxi mgt functions.) (VMX3 works too- I also manually matched physical MACs w. NICs in PF vm options- I don't know if that works better… or what) (the 100 speed is just my old switch- I wasn't sure if the new switch was bad or not.) (will put my other VMs on the LAN vswitch2)

    Enclosed are a couple pics (stock, wrong, and working)- so if others have this issue.... they can see how to fix.

    ![stock setup.PNG](/public/imported_attachments/1/stock setup.PNG)
    ![stock setup.PNG_thumb](/public/imported_attachments/1/stock setup.PNG_thumb)
    ![new vswitch config wrong.PNG](/public/imported_attachments/1/new vswitch config wrong.PNG)
    ![new vswitch config wrong.PNG_thumb](/public/imported_attachments/1/new vswitch config wrong.PNG_thumb)
    ![new vswitch config working.PNG](/public/imported_attachments/1/new vswitch config working.PNG)
    ![new vswitch config working.PNG_thumb](/public/imported_attachments/1/new vswitch config working.PNG_thumb)


Log in to reply