Weird DNS issue with pFsense



  • Hello all,

    I am truly hope someone can help me out with a issue i am having with pFsense. I currently run pFsense as a VM on a unraid system, for the most part it works great but i seem to have an issue with pFsense that any guest vm and the host itself cannot seem to resolve DNS properly, all other machines on the the network are fine and have no issues with DNS.

    I have tried troubleshooting this with no avail as im not really sure where to look and tried another flavor of FW sophus in exactly the same configuration as pfsense and there are no issues what so ever. As part of my troubleshooting i have created a sophos vm and a pfsense vm, when i spin down the pfsense VM and spin up the sophos vm all my DNS issues are resolved, no changes exactly the same default out of the box config applied which is as follows.

    assign my virutal interface to my lan adapter, assign my 2nd onboard nic to the wa put my isp configurations in setup dhcp with my dns being the router (192.168.1.254).

    When i spin down the sophos vm and spin up the pfsense vm all my ubuntu guest vm's loose update ability etc all relating back to DNS

    I would really appreciate it if someone could assist me with this issue as it's driving me nuts and i like using pFsense.

    I realise i've not posted much to go off so if someone would be in a position to tell me what info would be needed to assist it would be appreciated.



  • The hosts that work, and the ones that don't, are those all on the same network?



  • yes they are all on the same vlan and same network.

    I think i have further narrowed the issue down. It appears downgrading pfsense back to version 2.1.4 the issue is not present. upgrading to 2.2.1 no DNS. I recall the issue being introduced after a upgrade but hadn't proved it until now.

    2.1.4 install was done with the base x64iso and clean install - all worked fine
    2.2.1 install was done in two ways both failed upgrade via auto updater and install directly from base64 iso for fresh build - dns issues on virtual guests

    all with exactly the same config applied

    What i've noticed different between the versions is how my virtual adapter is referenced. in 2.1.4 the adapter is called em0 and in 2.2.x the adapter is called xn0.

    It def works perfect on 2.1.4 tho.



  • That's the general Xen problem with xn, need to disable offloading.
    https://forum.pfsense.org/index.php?topic=85797.msg475906#msg475906



  • Not the answer i was hoping for, because this is Xen as part of unraid i will need to wait until the next release of unraid. It's working on 2.1.4 of pFsense so i will stay with that until this is sorted.

    Thanks for the feedback.


Log in to reply