Really big problem to go to 2.2.2 from 2.2.1



  • After upgrade the errors come up :

    Kdb: debugger backend: ddb

    Amd64

    Restalling everything right now!!!


  • Banned

    No issues here.



  • Upgraded from 2.2.1 –> 2.2.2. After 1 hour the server is still booting. The boot process is not hung, its still loading slowly. Outputting to screen character by character - 1 char every 2-3  seconds.

    -Andrew



  • @ahking19:

    Upgraded from 2.2.1 –> 2.2.2. After 1 hour the server is still booting. The boot process is not hung, its still loading slowly. Outputting to screen character by character - 1 char every 2-3  seconds.

    Outputting what to the screen?



  • @cmb:

    @ahking19:

    Upgraded from 2.2.1 –> 2.2.2. After 1 hour the server is still booting. The boot process is not hung, its still loading slowly. Outputting to screen character by character - 1 char every 2-3  seconds.

    Outputting what to the screen?

    I'm having this exact same problem.
    It looks like the normal boot messages, but as soon as the boot menu is done it's progressing at about one character every 5 second.

    After 2 hours it got this far

    http://i.imgur.com/FlqtWPp.jpg

    Edit: and a video

    https://docs.google.com/file/d/0B3EMGKybvzsJMjRtWnhIV0t5dHM/edit?usp=docslist_api



  • It appeared on the snapshots since April 11. It is treated by replacing the top-level of directory /boot on the content from 10 April.



  • @Michael:

    It appeared on the snapshots since April 11. It is treated by replacing the top-level of directory /boot on the content from 10 April.

    do you know which file specifically? That timeline seems to match some loader.conf changes for serial console, but I don't see how that would impact things in that way. That's been tested on numerous different hardware platforms and VMs, not sure how other situations can be different.

    Those affected, are you running full installs or nano? What kind of hardware? Is the serial console enabled?



  • @cmb:

    @Michael:

    It appeared on the snapshots since April 11. It is treated by replacing the top-level of directory /boot on the content from 10 April.

    do you know which file specifically? That timeline seems to match some loader.conf changes for serial console, but I don't see how that would impact things in that way. That's been tested on numerous different hardware platforms and VMs, not sure how other situations can be different.

    Those affected, are you running full installs or nano? What kind of hardware? Is the serial console enabled?

    Full install, physical hardware, I don't recall my settings for serial console.



  • Here is a quick video of mine after just over an hour of booting.  Make sure and notice how slow the text is appearing.

    Youtube Video



  • @cmb:

    Those affected, are you running full installs or nano? What kind of hardware? Is the serial console enabled?

    Full install, intel hardware, default serial settings.



  • @cmb:

    do you know which file specifically? That timeline seems to match some loader.conf changes for serial console, but I don't see how that would impact things in that way. That's been tested on numerous different hardware platforms and VMs, not sure how other situations can be different.

    Those affected, are you running full installs or nano? What kind of hardware? Is the serial console enabled?

    Zotac IONITX-P-E, 4GB RAM, 1TB HDD. Full install AMD64. Serial console disabled.
    I don`t know which file specifically, but is top level of /boot - not a kernel. Can an experiment, but it will take some time.



  • Just took the upgrade and was sad to find out that I had the problem stated above. I am running the asrock q1900m system with 4gb of ram. I had serial console enabled. I went to the BIOS and disabled the serial port all together and rebooted. Upon reboot my system is back to normal. Boot up took normal amount of time.
    I have a full install upgrading from 2.2.1

    Any questions let me know I'll see what I can do.



  • Yup, same here, fixed!  I disabled the serial port and it's back up and normal.


  • Rebel Alliance

    Yup… same here

    Full install (64bits) on a "cheap" Asrock C70M1, 8Gb of RAM, 80Gb SATA HDD.

    "Solved" disabling "Serial port"



  • @cmb:

    do you know which file specifically? That timeline seems to match some loader.conf changes for serial console, but I don't see how that would impact things in that way. That's been tested on numerous different hardware platforms and VMs, not sure how other situations can be different.

    Immediately after the upgrade file loader.conf contains:

    
    boot_serial="YES"
    comconsole_speed="9600"
    hw.usb.no_pf="1"
    
    

    Сleaning it solves the problem.



  • @cmb:

    Those affected, are you running full installs or nano? What kind of hardware? Is the serial console enabled?

    FWIW, I'm running on a cheapo eMachines w/ Atom processors and was having the same issue with the upgrade (full install). Wiping back to a clean install booted fine, but as soon as I imported my old config, it would slow down again.

    I don't recall what the status of the serial console was initially, but like the others above, disabling my serial port in the BIOS allowed it to boot up normally.



  • I did a fresh install of 2.2.2 and restored my config.
    Immediately after that, it did the slow down again.

    Disabling the serial port in my bios fixed it for me as well.

    this is a low risk upgrade

    To everyone in this thread.  I recommend NEVER playing Russian Roulette.



  • Hi,

    Upgrade from full install of 2.2.1 to 2.2.2 on a

    Intel DQ77KB
    Xeon E3-1265v2
    8GB 40GB Intel mSATA SSD

    Running pfsense without problems for about a year. Same problem where the system boots character by character with a speed reminding me of my first 150 baud modem :). Disabled the serial port and the system boots fine with connectivity restored. I forgot to check which BIOS version I had installed, I'll check upon request. Just filing to perhaps aid in finding a pattern. Thanks folks for finding a workaround so fast.




  • @Michael:

    Immediately after the upgrade file loader.conf contains:

    
    boot_serial="YES"
    comconsole_speed="9600"
    hw.usb.no_pf="1"
    
    

    Сleaning it solves the problem.

    Thanks, that's helpful. I think it's the boot_serial line on its own that does it, but have no means of confirming as it seems to be somehow hardware-specific.



  • @Michael:

    Zotac IONITX-P-E, 4GB RAM, 1TB HDD. Full install AMD64. Serial console disabled.
    I don`t know which file specifically, but is top level of /boot - not a kernel. Can an experiment, but it will take some time.

    I have similar hardware but Atom based…

    Disabling the serial port fixed the problem, thank you jwhostet (I believe he is the first one who suggested disabling the serial port)!

    I guess it's trying to access a serial console and stays stuck there...

    Is it possible to temporarily deactivate offering the update until this is fixed so that nobody else gets caught without Internet access? The forum is not very mobile friendly so it was a pain to search for a fix...

    Nick



  • It acts like it's sending a serial char out, waiting for a reply, timing out then moving on.



  • @cmb:

    Thanks, that's helpful. I think it's the boot_serial line on its own that does it, but have no means of confirming as it seems to be somehow hardware-specific.

    Apologies for being mostly BSD illiterate, is there any way that I can grab more (possibly useful) information for you from at least my system?



  • My loader.conf (I assume it is the one under /boot) contains more stuff but it has the same serial line…

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="0"
    boot_serial="YES"
    comconsole_speed="9600"
    hw.usb.no_pf="1"
    
    

    Nick



  • I ran into the same issue on upgrade from 2.2.1 to 2.2.2.  Going into the BIOS and disabling the serial ports got me around it.



  • Yeah, well serves me right for doing updates the first day they are released…. I had the same problem, and after watching the copyright dates slowly filter through at the rate of 7 seconds per character for 20 minutes, I managed to find an old pfsense 2.0 cd and was able to get online to check the forums.

    Disabling the serial port fixed it and i am on 2.2.2 now, with no serial ports. 
    motherboard is p5Ld2-vm http://www.asus.com/Motherboards/P5LD2VM/



  • So why do y'all have your serial port enabled if you are not using it.  Didn't your ma'ma ever teach you to turn off the lights when you leave a room vacant.  Less is more.

    If it ain't being used put it away, put it into storage, throw it away, turn it off.  Get the picture?  It's the same sort of philosophy as with security.  Only what is needed is permitted, stored/kept, provided, etc.

    First thing I did when initially setting up my pfSense machine was go into the BOIS and turn off everything not being used.  Like the built in modem (yeah it's that old), printer port, etc.

    Less is more.

    Some times we people are our own worst enemy.



  • @NOYB:

    So why do y'all have your serial port enabled if you are not using it.

    Why would we turn it off unless we needed the resources (mostly IRQ) for another device or if it was a security risk?

    Didn't your ma'ma ever teach you to turn off the lights when you leave a room vacant.  Less is more.

    I don't think you will save energy by turning it off especially considering that the chip involved do other things as well…

    If it ain't being used put it away, put it into storage, throw it away, turn it off.  Get the picture?

    No, should we?

    It's the same sort of philosophy as with security.  Only what is needed is permitted, stored/kept, provided, etc.

    I agree with you here but here there is actually a good and valid reason to do it…

    First thing I did when initially setting up my pfSense machine was go into the BOIS and turn off everything not being used.  Like the built in modem (yeah it's that old), printer port, etc.

    Built-in modem? What is it, a PCJr? I have had plenty of PCs (and even non PCs like Apple II compatible and Sinclair ZX81) and I don't recall any of them ever had a built-in modem.

    Less is more.
    Some times we people are our own worst enemy.

    If you did not have the number of posts you have here I would have hesitated between thinking this was flame bait or trolling…

    I doubt this is the case considering your implication here but this is what it seemed to be at first glance...

    Nick



  • @Crescens:

    Apologies for being mostly BSD illiterate, is there any way that I can grab more (possibly useful) information for you from at least my system?

    If you wouldn't mind, if you can try it after removing only the boot_serial line, that would at least verify the exact cause, which is enough we can fix it (by making sure that doesn't get added in that way).



  • @Knight:

    My loader.conf (I assume it is the one under /boot) contains more stuff but it has the same serial line…

    It will, the earlier snippet was just a part of his.

    @NOYB:

    So why do y'all have your serial port enabled if you are not using it.  Didn't your ma'ma ever teach you to turn off the lights when you leave a room vacant.  Less is more.

    For sound cards, and other potentially more-intrusive hardware, I agree. Remove it if possible, disable it in the BIOS otherwise. Serial ports, prior to now I'd never seen having those enabled be an issue (and it still isn't, really, outside of working around this I still wouldn't bother disabling serial ports).

    @Trel:

    this is a low risk upgrade

    To everyone in this thread.  I recommend NEVER playing Russian Roulette.

    Good advice. :) For the hardware we test it's low risk at least. I hate that change broke things for some of you. We missed that as it didn't impact anything we sell or test using, and apparently only one person hit it prior to release (which we thought was a one-off issue specific to one person's system since our significant testing didn't show any such issues across a variety of platforms).



  • I added a warning to the release announcement on this issue.



  • Wow thanks for posting this, i just worked on my box for 3 hours it's 12:30 in the morning and disabling the serial port in the bios fixed the issue.  Full install from 2.2.1 to 2.2.2.  I reinstalled from scratch 2.2.2 and it would install and reboot fine, as soon a i reload my backuped 2.2.1 config and it reboots, is when it start printing out slow.  I even restored sections of my config and some sections would load fine and a reboot would still work. It would eventually always break though.



  • @Knight:

    . . .
    Nick

    Because cause if it is not being used there is no good that can come from it being enabled.  Only bad.  KISS and avoid the bad.  Like this issue, you never now when it will sneak up and bite.
    Disabling things in the BIOS that are not being used is not about saving energy.  It's about KISS.
    Yes, you should be getting the picture.
    There is a good and valid reason to do so here too.  Apply the KISS principle to things and life is easier.
    Many notebooks back in the dial-up days had built-in modems.

    Not a troll.  It's a serious message.  I really don't get leaving all that junk enabled if it is not being used.  Just makes no sense for router appliance that is desired to be as reliable as possible.  Less is more.

    It's a prudent KISS to turn it off.  In the words of Nike.  Just do it!  And be done with it.



  • Alright.  Who gave me my first smite?

    Can't believe someone would smite over this.



  • Som critical info is missing here: when/how will this be solved, will we get an "emergency" update? Should I wait for an update or is this one of such importance that I should go with the update? I don't use IPv6, IPSEC, wireless and the web interface can't be accessed from WAN so I think the openssl vulnerabilities don't apply, please correct me if I am wrong. And I trust my LAN. Any other reasons?

    No other problems - only that since 2.2.1 and the other package updates I can't connect with openVPN (network manager) from my openSUSE 13.1; I keep up to date my openSUSE workstation. Works fine from Fedora or Android so I think the openSUSE dudes/updates messed something up, I will investigate.



  • Is there any boot option we could use to override the setting thats caused this? My system has no serial port setting in the bios :(



  • Same problem here.

    Hardware: Asrock AMD E350M1
    pfSense: Full install
    Solution: Disable serial port in BIOS

    Will changing boot_serial="YES" to boot_serial="NO" in /boot/loader.conf solve the problem permanently?



  • @mir:

    Will changing boot_serial="YES" to boot_serial="NO" in /boot/loader.conf solve the problem permanently?

    sortof. "/boot/loader.conf" gets overwritten every time you update/reinstall pfSense. But the devs are aware of the issue now, so in the next release, they should have a permanent fix for it.



  • @NOYB:

    Because cause if it is not being used there is no good that can come from it being enabled.  Only bad.  KISS and avoid the bad.  Like this issue, you never now when it will sneak up and bite.
    Disabling things in the BIOS that are not being used is not about saving energy.  It's about KISS.
    Yes, you should be getting the picture.
    There is a good and valid reason to do so here too.  Apply the KISS principle to things and life is easier.
    Many notebooks back in the dial-up days had built-in modems.

    Not a troll.  It's a serious message.  I really don't get leaving all that junk enabled if it is not being used.  Just makes no sense for router appliance that is desired to be as reliable as possible.  Less is more.

    It's a prudent KISS to turn it off.  In the words of Nike.  Just do it!  And be done with it.

    Still not sure if troll or not when you advocate disabling serial on a firewall "to keep it simple". You should rather fix the issue and keep the serial there so you can use it in case of emergency.


  • Banned

    As I run it in a VM at home with no serial port connected, then no issues.

    When I add the port, I get the issue described.



  • @mococanet:

    After upgrade the errors come up :

    Kdb: debugger backend: ddb

    Amd64

    Restalling everything right now!!!

    Yes, same problem!
    I try upgare and fresh install. But same result.

    Restart to my Pfsense

    Very very slowly write: Kdb: …......................

    This is big problem!


Log in to reply