OpenVPN юзеры видят LAN, нет доступа к WAN



  • Коллеги, вот схема сразу:

    Сейчас OpenVPN сервер настроен вроде правильно. Все юзеры на Android, iOS, W7 отлично подключаются к нему, при этом видят LAN и WAN.

    НО есть еще одна подсеть за двумя NAT (это Asus RT-N10U). Который как клиент OpenVPN отлично подключается к серваку, видит LAN, но абсолютно нет WAN :) В правилах вроде ничего не запрещает:

    Еще я не могу понять в чем дело, но когда вручную отключается клиента OpenVPN на Asus RT-N10U и подключаешь заново - все становится в порядке. Видит и LAN и WAN. Думаю, что в роутинге дело, но в какой части, то ли на серваке, то ли в настройках Асуса - не доходит. Опять же смущает, что все остальные отлично подключаются. Помогите плз разобраться !



  • галки на ван интерфейсе сними "блокировать приват сети"  :)
    и посмотри что в логах пишет.



  • 2 alvian :

    pfsense полнимает линк и gpon-модем? Судя по схеме OpenVPN у вас на LAN висит? Если - да , то почему так ?

    P.s. Настоятельно рекомендую сменить dd-wrt на TomatoUSB (http://tomato.groov.pl/?page_id=31)
    С этой прошивкой и OpenVPN проблем не было.



  • @werter:

    2 alvian :

    pfsense полнимает линк и gpon-модем? Судя по схеме OpenVPN у вас на LAN висит? Если - да , то почему так ?

    P.s. Настоятельно рекомендую сменить dd-wrt на TomatoUSB (http://tomato.groov.pl/?page_id=31)
    С этой прошивкой и OpenVPN проблем не было.

    У меня тут уже голова вскипела просто ! pfSense у меня подключен к gpon-модему и находится у него в DMZ.

    Но долбанный Asus RT-N10U не понимает 4G, поэтому пришлось колхозить и юзать из-за этого 2 роутера. 1 - который принимает 4G, 2 - который поднимает OpenVPN.

    Спасибо за Tomato, сейчас буду ставить, как раз на мой RT-N10U там есть прошивка… Отпишусь чуть позже!



  • @alvian:

    Спасибо за Tomato, сейчас буду ставить, как раз на мой RT-N10U там есть прошивка… Отпишусь чуть позже!

    После перепрошивки обязательно сбросьте NVRAM.



  • @werter:

    @alvian:

    Спасибо за Tomato, сейчас буду ставить, как раз на мой RT-N10U там есть прошивка… Отпишусь чуть позже!

    После перепрошивки обязательно сбросьте NVRAM.

    Прошился на Tomato, но 4G свистульку Yota (LU-150) не видит :(
    NVRAM скинул, т.е. я выключил роутер, включил с зажатой на 10 сек кнопкой WPS, так ведь ? ;) Похоже, что придется на dd-wrt возвращаться и колдовать дальше..



  • Прошился на Tomato, но 4G свистульку Yota (LU-150) не видит

    Как проверяли видимость ? Опишите. Что команда dmesg | grep usb выдает в консоли ( или lsusb) ?

    NVRAM скинул, т.е. я выключил роутер, включил с зажатой на 10 сек кнопкой WPS, так ведь ?

    Нет. Сбрасывается из веб-фейса. Ищите статьи по перепрошивке.



  • Наконец удалось подружить мой Asus RT-N10U с Yota. Пришлось только заменить модем Yota (LU-150) на Huawei 392 (цена вопроса 950 руб. залоченного + 5 евро разлочка).

    Теперь ситуация такая. Клиент Tomato подключается к OpenVPN. Соединение не разрывается, все ок. Есть доступ к WAN, НО теперь нет доступа к LAN (за pfSense). Хотя настройки необходимые есть:

    На pfSense в Client Specific Override > Advanced:
    iroute 192.168.1.0 255.255.255.0;
    ifconfig-push 192.168.4.14 192.168.4.13;

    На pfSense в настройках сервера в Advanced configuration > Advanced:
    route 192.168.70.0;

    На Tomato в настройках OpenVPN клиента:
    route 192.168.1.0;
    pull

    Что-то упустил или в чем дело ??

    p.s.
    В FW pfSense разрешающее правило есть !



  • Дописываю свою ситуацию.

    Сейчас доступ к WAN, LAN есть со стороны клиента. Клиент OpenVPN (прошивка tomato на asus rt-n10u).
    По telnet, ssh из сети сервера доступ к роутеру есть. Но на webgui зайти не могу.

    Объясните плз в чем дело?! Не понимаю…

    Ниже, обновленная схема сети (проблема где сеть 192.168.70.0):


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy