Question about clone interface / 20Mhz width



  • Hi,

    I've just built a router based on pfsense using the APU1D4 kit (msata, compex/atheros pcix wireless card etc).  Everything is running fine, but I'd like to use 20Mhz channel width rather than 40 (which the card/pfsense defaults to).  I can't seem to find anywhere in the GUI that allows selection of 20Mhz, the channel select only offers the frequency with a bank of 2.5Ghz and 5Ghz.  Is it possible to specify the channel width from the GUI?

    I did use ifconfig from a cmd prompt to change the width using

    ifconfig ath0_wlan0 channel 4:ht/20
    

    This works ok, but doesn't get saved in the config, so reverts back to ht/40+ everytime the properties are saved or the device is rebooted.

    The card is WLE200NX, Atheros chipset AR9280

    Finally, there is a really strange issue that seems to be occurring when using a VAP/ cloned interface.  It appears that I am unable to set 20Mhz channel width on both the primary interface and the secondary (clone) at the same time.  I can set ath0_wlan0 to ht/20, but when I try to change ath0_wlan1 to ht/20 it works, but causes ath0_wlan0 to jump back to ht/40+.  It's impossible to get them both on ht/20 at the same time for some reason.  inSSIDer confirms that at any one time, only one of the SSIDs is running on 20Mhz, and the other is running on 40Mhz width.  I've tried lots of combinations of commands to attempt to get this to work including downing both interfaces and changing the setting (which does work and shows both at ht/20), but as soon as they are back up, one of them reverts to ht/40+.

    Other than these wireless issues, the router is fantastic, and so much better than the TomatoUSB ASUS I was running previously in terms of functionality and manageability.  I know pfsense (or rather FreeBSD) isn't supposed to be the best option for an access point, but just thought I would ask to see whether anyone has an idea on why it's behaving this way.

    edit All this is on pfsense 2.2.2-RELEASE, full install btw.  Thanks.



  • Oh man! similar question here, but not really interested to change from 40 to 20 mhz width but I would know to setup all four clones supported by WLE200NX , for specific dual band operation exactly two clones on 5 ghz band and other two for 2.4ghz band.

    Not really sure if it's possible to do. (really?) lol…

    Well a starting point may to be reading https://wiki.freebsd.org/dev/ath(4)/80211n

    I follow the directive and list all channels supported below:

    [2.3.1-RELEASE][admin@pfSense.ballishome]/root: ifconfig -v ath0_wlan0 list channel
    Channel  1 : 2412      MHz 11b          Channel  11 : 2462      MHz 11g ht/20   
    Channel  1 : 2412      MHz 11g          Channel  11 : 2462      MHz 11g ht/40- 
    Channel  1 : 2412      MHz 11g ht/20    Channel  12 : 2467      MHz 11b         
    Channel  1 : 2412      MHz 11g ht/40+  Channel  12 : 2467      MHz 11g         
    Channel  2 : 2417      MHz 11b          Channel  12 : 2467      MHz 11g ht/20   
    Channel  2 : 2417      MHz 11g          Channel  13 : 2472      MHz 11b         
    Channel  2 : 2417      MHz 11g ht/20    Channel  13 : 2472      MHz 11g         
    Channel  2 : 2417      MHz 11g ht/40+  Channel  13 : 2472      MHz 11g ht/20   
    Channel  3 : 2422      MHz 11b          Channel  36 : 5180      MHz 11a         
    Channel  3 : 2422      MHz 11g          Channel  36 : 5180      MHz 11a ht/20   
    Channel  3 : 2422      MHz 11g ht/20    Channel  36 : 5180      MHz 11a ht/40+ 
    Channel  3 : 2422      MHz 11g ht/40+  Channel  40 : 5200      MHz 11a         
    Channel  4 : 2427      MHz 11b          Channel  40 : 5200      MHz 11a ht/20   
    Channel  4 : 2427      MHz 11g          Channel  40 : 5200      MHz 11a ht/40- 
    Channel  4 : 2427      MHz 11g ht/20    Channel  44 : 5220      MHz 11a         
    Channel  4 : 2427      MHz 11g ht/40+  Channel  44 : 5220      MHz 11a ht/20   
    Channel  5 : 2432      MHz 11b          Channel  44 : 5220      MHz 11a ht/40+ 
    Channel  5 : 2432      MHz 11g          Channel  48 : 5240      MHz 11a         
    Channel  5 : 2432      MHz 11g ht/20    Channel  48 : 5240      MHz 11a ht/20   
    Channel  5 : 2432      MHz 11g ht/40+  Channel  48 : 5240      MHz 11a ht/40- 
    Channel  5 : 2432      MHz 11g ht/40-  Channel  52 : 5260*    MHz 11a         
    Channel  6 : 2437      MHz 11b          Channel  52 : 5260*    MHz 11a ht/20   
    Channel  6 : 2437      MHz 11g          Channel  52 : 5260*    MHz 11a ht/40+ 
    Channel  6 : 2437      MHz 11g ht/20    Channel  56 : 5280*    MHz 11a         
    Channel  6 : 2437      MHz 11g ht/40+  Channel  56 : 5280*    MHz 11a ht/20   
    Channel  6 : 2437      MHz 11g ht/40-  Channel  56 : 5280*    MHz 11a ht/40- 
    Channel  7 : 2442      MHz 11b          Channel  60 : 5300*    MHz 11a         
    Channel  7 : 2442      MHz 11g          Channel  60 : 5300*    MHz 11a ht/20   
    Channel  7 : 2442      MHz 11g ht/20    Channel  60 : 5300*    MHz 11a ht/40+ 
    Channel  7 : 2442      MHz 11g ht/40+  Channel  64 : 5320*    MHz 11a         
    Channel  7 : 2442      MHz 11g ht/40-  Channel  64 : 5320*    MHz 11a ht/20   
    Channel  8 : 2447      MHz 11b          Channel  64 : 5320*    MHz 11a ht/40- 
    Channel  8 : 2447      MHz 11g          Channel 149 : 5745      MHz 11a         
    Channel  8 : 2447      MHz 11g ht/20    Channel 149 : 5745      MHz 11a ht/20   
    Channel  8 : 2447      MHz 11g ht/40-  Channel 149 : 5745      MHz 11a ht/40+ 
    Channel  9 : 2452      MHz 11b          Channel 153 : 5765      MHz 11a         
    Channel  9 : 2452      MHz 11g          Channel 153 : 5765      MHz 11a ht/20   
    Channel  9 : 2452      MHz 11g ht/20    Channel 153 : 5765      MHz 11a ht/40- 
    Channel  9 : 2452      MHz 11g ht/40-  Channel 157 : 5785      MHz 11a         
    Channel  10 : 2457      MHz 11b          Channel 157 : 5785      MHz 11a ht/20   
    Channel  10 : 2457      MHz 11g          Channel 157 : 5785      MHz 11a ht/40+ 
    Channel  10 : 2457      MHz 11g ht/20    Channel 161 : 5805      MHz 11a         
    Channel  10 : 2457      MHz 11g ht/40-  Channel 161 : 5805      MHz 11a ht/20   
    Channel  11 : 2462      MHz 11b          Channel 161 : 5805      MHz 11a ht/40- 
    Channel  11 : 2462      MHz 11g          Channel 165 : 5825      MHz 11a

    Next I try to changhe HT mode as follows

    [2.3.1-RELEASE][admin@pfSense.ballishome]/root: ifconfig ath0_wlan1 channel 6:ht/20

    [2.3.1-RELEASE][admin@pfSense.ballishome]/root: ifconfig ath0_wlan0 channel 10:ht/20
    ifconfig: SIOCS80211: Invalid argument

    ath0_wlan1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    ether 04:f0:21:1e:59:1a
    inet6 fe80::6f0:21ff:fe1e:591a%ath0_wlan1 prefixlen 64 scopeid 0x9
    inet 192.168.11.1 netmask 0xffffff00 broadcast 192.168.11.255
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
    ssid 1test channel 6 (2437 MHz 11g ht/20) bssid 04:f0:21:1e:59:1a
    regdomain APAC country US ecm authmode WPA2/802.11i privacy MIXED
    deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 1 scanvalid 60
    protmode CTS ampdulimit 64k ampdudensity 8 shortgi wme burst -apbridge
    dtimperiod 1 -dfs
    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    ether 06:f0:21:1e:59:1a
    inet6 fe80::4f0:21ff:fe1e:591a%ath0_wlan0 prefixlen 64 scopeid 0xa
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
    ssid Ospiti channel 6 (2437 MHz 11g ht/40+) bssid 06:f0:21:1e:59:1a
    regdomain APAC country US ecm authmode OPEN privacy OFF txpower 1
    scanvalid 60 pureg protmode CTS ampdulimit 64k ampdudensity 8 shortgi
    puren wme burst -apbridge dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>

    What happening? Changes of HT width is effective only if you deal with psychical interface, not with clone !? WTF

    Next I try to remove parent interface from main configuration assignment, and play only with clones interface, just for stating to assign all clones supported by wireless card, in pfsense > interfaces > wireless I make all clone  can do it right but ensure to remove all previos parent interface from configuration. Otherwise I unable to set up all four clones in hostapmode.

    Well done, after configuring all interfaces and up on reboot the ht/20 is unable to set more than one interface at time, and last clone interface refuse to set with error ifconfig: SIOCS80211: Invalid argument

    [2.3.1-RELEASE][admin@pfSense.ballishome]/root: ifconfig | grep ht
    ssid 1test channel 60 (5300 MHz 11a ht/20) bssid 04:f0:21:1e:59:1a
    ssid Ospiti channel 60 (5300 MHz 11a ht/40+) bssid 06:f0:21:1e:59:1a
    ssid 2test5G channel 60 (5300 MHz 11a ht/40+) bssid 0e:f0:21:1e:59:1a
    ssid 3test5G channel 40 (5200 MHz 11a ht/40-) bssid 0e:f0:21:1e:59:1as clone. tis is bad thing for me.

    Another strange thing is under create new last clone, the clone get same bssid of previous clone i made.

    In additional notice if I try to setup channels for dual band with two ssid on 2.4ghz and other two on 5ghz , when all configured and up the interfaces report same channels!  And if I try to change one clone , the change reflect on all others. Very sad.
    (A side note) I remember few days ago during test I got dual channel setup (one ssid in channel 1 and another in channel 6) for 2.4ghz band , unfortunatley  not stable and unable to connect  to. Also I unable to replicate this behavior at least for now. I don't know how to make thing working lol!

    Reading https://wiki.freebsd.org/AdrianChadd/AtherosTxAgg
    give me no more info about possible dual channel operation.

    In dmesg the ath driver report this:

    [2.3.1-RELEASE][admin@pfSense.ballishome]/root: dmesg |grep ath
    ath0: <atheros 9280="">mem 0xf7e00000-0xf7e0ffff irq 19 at device 0.0 on pci4
    [ath] enabling AN_TOP2_FIXUP
    ath0: [HT] enabling HT modes
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9280 mac 128.2 RF5133 phy 13.0
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    wlan0: changing name to 'ath0_wlan1'
    wlan1: changing name to 'ath0_wlan2'
    wlan2: changing name to 'ath0_wlan3'
    wlan3: changing name to 'ath0_wlan4'</atheros>

    and over uptime few notice appear like:

    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_reset: concurrent reset! Danger!

    Please if anyone know what is possible or impossible to do with single WLE200NX module
    please clarify the status of possible running mode with freebsd/pfsense current ath driver.
    I found one another post write about this "issue" but not really clarifing who is the problem.

    Thanks in advance.



  • Impossible to do. Some Atheros modules support either 2ghz or 5ghz but not both bands simultaneously.
    Not supported on ANY operating system. A module for each band is possible.



  • I also have been looking at setting 20 MHz channel width from the WebUI and could not find a way to do it. Is this supported?

    The reason I am looking for this is that my 2.4 GHz AP defaults to 40 MHz and you can imagine with all the neighbouring APs causing a lot of radio noise the performance and stability is affected.


  • LAYER 8 Global Moderator

    This thread is from over a year ago, and really no traction in at all.

    What I would suggest to future readers - is if you want to play with fancy wifi stuff.. Get a real AP ;)



  • Netgate intended their own hardware to support wireless networks since they sold their boxes with onboard wireless adapters. They've recently switched to bundling external APs in a move that looks like they're giving up on onboard wireless.

    I'd argue that ensuring 2.4 GHz radio uses a 20 MHz channel by default in pfSense should be a priority as it makes 2.4 GHz wireless pretty much useless otherwise.


  • LAYER 8 Global Moderator

    I would argue that trying to run a wifi network off some wifi card you put in a computer no matter what OS its running is useless before you even attempt it.  If you want wifi network then get a AP and properly locate it for best coverage, more than likely you will need multiple AP to cover your area you want good wifi in.

    Dropping sale of wifi cards for their boxes has been prob best move they have done ;)  Wasting time trying to do something that even if done as best as possible would always be just a crappy wifi.. In what scenario would pfsense be correctly deployed to allow for best coverage via the crappy little card you put in it?


  • Global Moderator


Log in to reply