How to make GTA 5 on PC work



  • I was having major problems joining sessions and connecting to heists.  After much frustration, I've found what fixes the problem.

    1. Go to Diagnostics->Backup/Restore->Download configuration (save the file to your computer.  congrats you backed up your current config)

    2. Set a static DHCP lease for the computer you're going to be playing on.

    3. Go to Firewall->NAT->Outbound

    *Change the Mode to: Hybrid Outbound NAT rule generation and hit save.

    *Add a NAT rule:
    Interface: WAN
    Protocol: any
    Source: type - network, address - the_static_dhcp_lease_ip_you_just_set /32
    Translation: Static-port (check the box)
    Click save

    Click apply and restart pfSense.

    1. Go to Firewall->Rules and create the following port forward rules:

    UDP Ports: 6672, 61455, 61457, 61456, and 61458

    Example:



  • My, my, how nice. I was looking actually for a solution for that problem lately!



  • This isnt really the best way to do it.  By doing it this way you are disabling source port randomization for ALL outbound ports on whatever IP you specify.  This isnt actually necessary at all.  You can just specify that any IP on your lan that uses those ports will have them be static going out.  You do that like the screenshot I attached.  Still open the ports (under NAT, Port forward, not rules)  You dont need to enable Automatic mapping either, Advanced works fine.

    Keep in mind guys, on a firewall you dont want to open any more that's necessary than for it to function correctly.  Anything more is a security hole.




  • i know this is old... but...

    @autotalon

    i would love to see this screenshot you are talking about :D