PFsense con router telecom italia



  • Buongiorno a tutti

    mi sono ritrovato (mio malgrado) a configurare un fw pfsense che utilizza come rete Wan una connessione Alice Adsl con 1 ip fisso.
    Per quanto riguarda la navigazione tutto funziona correttamente , i pc della rete escono tramite il fw che ha impostato come GW l'indirizzo ip (192.168.1.1) del router telecom.
    Fin qui tutto bene , il problema nasce quando devo Nattare o creare una VPN.
    Il router telecom natta l'ip pubblico su un ip locale che di conseguenza diventa il gw del firewall , pensavo bastasse configurare i virtual server sul router in maniera che indirizzassero tutte le richieste su determinate porte verso l'ip del fw , in modo da fare un doppio nat… ma sono stato troppo ottimista... il fw non ne vuole sapere di essere raggiunto dall'esterno.

    Qualcuno ha qualche consiglio per risolvere questo problema?

    Grazie

    Fabio



  • Io ho risolto in questo modo:

    Ho sostituito il router Telecom con un altro router dove non ho configurato la connessione WAN, poi ho configurato la WAN di pfSense per una connessione PPPoE con user e password relative alle connessioni Telecom Business, ovvero con IP statico (non ricordo ma se googli trovi molte indicazioni in italiano…)

    A questo punto l'IP statico viene assegnato direttamente alla WAN di pfSense e non avrai più nessun problema.

    Ciao Eligio.



  • Grazie Eligio!

    Facendo così funziona, però dall'esterno riesco a raggiungere solo l'interfaccia del fw (porta 80 o 443) , se faccio un nat a un server non me lo vede,la stessa configurazione per il NAT se la uso con un un interfaccia statica "classica" funziona correttamente.
    Hai qualche suggerimento?

    Grazie

    Fabio



  • Se scrivi così mi viene da pensare che commetti qualche errore nella creazione della regola NAT.

    Se ho capito bene, ci sono due scenari (utilizzo IP di esempio):

    Scenario 1:

    IP WAN modem Telecom: 55.66.77.88
    IP LAN modem Telecom: 192.168.1.1
    IP WAN pfSense: 192.168.1.2
    IP LAN pfSense: 192.168.0.1

    In questo caso configurando una regola di nat sia sul modem che su pfSense funziona.

    Scenario 2:

    IP WAN modem Telecom: nessuno
    IP LAN modem Telecom: 192.168.1.1
    IP WAN pfSense: 55.66.77.88
    IP LAN pfSense: 192.168.0.1

    In questa caso configurando la regola di nat solo su pfSense non funziona

    Se la tua situazione è quella descritta è probabile che ci sia un errore nella creazione della regola nat, posta uno screenshot e vediamo.

    A presto, Eligio



  • Oppure un'alternativa è creare una regola sul modem/router di telecom verso l'indirizzo ip di pfsense mettendo un asterisco nel box delle porte, cosi facendo imposti una dmz verso pfsense. Cosi facendo puoi creare delle regole ad-hoc su pfsense



  • Infatti, puoi fare come dice darkosx. Anch'io ho sempre (quasi) risolto in questo modo.



  • Ciao,
    e una soluzione solitamente scontata..
    dipende dal router Telecom
    dovresti poter abilitare il PPPoE relay o passthrough .
    con questo sistema utilizzi il router come se fosse un modem e mantieni il mac/seriale che Telecom si aspetta…....
    poi lo colleghi con pfsense sulla wan come pppoe.....
    se tutto funziona avrai sulla wan del pfsense l'indirizzo ip pubblico senza avere una sgradita nat in più da gestire

    ciao


Log in to reply