VPN not working from other countries



  • Im new in the vpn world so please bare with me!i have made a vpn server and its working awesome from android and from PC-s but when i leave the country i can connect to the VPN but i cant browse the internet only from Android device. I need to use the internet thru VPN.Please verify if the setting are good :-
    ![firewall.local - OpenVPN- Server 2015-05-05 08-28-12.png](/public/imported_attachments/1/firewall.local - OpenVPN- Server 2015-05-05 08-28-12.png)
    ![firewall.local - OpenVPN- Server 2015-05-05 08-28-12.png_thumb](/public/imported_attachments/1/firewall.local - OpenVPN- Server 2015-05-05 08-28-12.png_thumb)



  • Basically the config doesn't matter the accessibility depending on where the connection is coming from.

    Rather I think, your roaming provider is blocking the connection to UDP 1194. So I would try to change these settings to 443, 80, 25, 465, 993 TCP, any common port, you don't use otherwise. Maybe it also works with UDP 53, but I entertain some doubt.



  • The problem is that i have installed openvpn on my phone and i have been connected to the same wifi as my laptop. The laptop can access the vpn network and it can ping and access the router on 192.168.5.1 but i cant access the internet. I can do the same on my phone and i can access the internet. I can't figure out why is it working on my phone i it is not working on my laptop.



  • Okay, I misinterpreted your first post. So forget my former answer.

    pfSense will not differ, which device wants to access the internet.
    This looks like a DNS issue. Could be that the DNS (I think your providers), your phone is configured to use, is not reachable or doesn't respond to requests from other countries.

    Best way to resolve will be to check "DNS Servers" in ovpn server config and enter your DNS servers there to push it to clients.
    Otherwise you can also set it at your Android in VPN settings.



  • ok, i have made the modifications.I have selected the "DNS Servers" and enterd the ip (192.168.5.1 this is my pfsense box) and selected the "Force DNS cache update" . I hope this will fix my problem :)



  • It is working! if somebody has this problem just add the google DNS or your internet provider DNS and its working!Thanks for the help ! ;D