Lost webGUI after moving to a new VM



  • Hello,

    Recently, I moved my servers from one VMware ESXi 5.5 box to a new VMware ESXi 6 box. Almost everything made the transition well. VMware 6 is fantastic. My pfSense box is working but I cannot access the webGUI.

    The webGUI was HTTPS port 10443. When I moved to the new VM, the network adapters appeared differently. I reassigned them using the console. After reassigning them, the firewall works but I cannot access the webGUI. I've tried HTTP, HTTPS, etc. All other VM networking works on my other virtual machines.

    I'm somewhat experienced with pfSense and FreeBSD but I wanted to ask for help before pounding the command line and wrecking my firewall. Also, I have a few configurations in place that make restarting from scratch a bit painful. Besides, this is an opportunity to learn.

    Thanks.


  • Banned

    When you set interface IP address, then it asks you what port you want to use for the GUI.

    Set it to 80 or 443.

    Be aware that VmWare has certain ports open for access on the VM's and 10443 could easily be closed in the internal VM network.



  • I read your post, then re - Set Interface(s) IP Address. I went through the steps (WAN, LAN, OPT, DHCP) but it did not ask me for port information.

    After resetting the interfaces, I'm shown HTTPS://<lan ip="">:10443 as the management interface.</lan>


  • Banned

    Its in the end…




  • I'm using Option 2 - Set Interface(s) IP Address. I'm never asked to choose the port. Here's my last steps.



  • Banned

    Hmmm. I run 2.2.2 at home in a VM and that should be the same.

    Another question… why you run a /8 subnet??



  • Yes. Odd.  Mine is 2.2.2 on a VM. I'm also at home (pfSense "Home Firewall" detection.
    /8 is temporary while I fix pfSense. My work VPN is done upstream of pfSense until I get this running properly again. DHCP gives me a /8 so I can get to work and home private IPs.



  • Fixed.

    For those of you just joining, I edited config.xml and replaced the webGUI port from 10443 to port 80. Once I did that, I could access the webGUI normally.