Squid non-transparent proxy sorunu



  • Pfsenseyi non-transparent olarak kullanıyorum. Https engelleme ve ultrasurf için tek çözüm bu olarak düşündük. Yalnız birkaç sorun ile karşı karşıyayız. Sistemde squid-squidguard-lightsquid kurulu. Bu eklentilerin hepsi gayet düzgün çalışıyor.

    1. Ftp (filezilla) ile hostinge bağlantı kuramıyoruz. gerekli nat ayarlarını yaptık fakat bağlantı hala kurulamıyor. squid bir şekilde engelliyor.

    filezilladan aldığımız hata: Durum: "EAI_NONAME - Nodename ya da servname belirtilmedi ya da bilinmiyor" ile bağlantı kurulamadı.

    servname yerine direk hostingin ip adresini yazdığımızda ise bağlantıya başlıyor fakat dosyaları görüntülemiyor. Burda bir dns sorunun da olduğunu düşünüyoruz.

    2. bazı sitelere girdiğimizde örneğin forum.pfsense.org :) ilk olarak web siteyi yok diyor fakat sonra site açılıyor bazen ise tarayıcıdan yenilemek gerekiyor. Genelde bunu https linklerde yapıyor.

    nat kurallarımızı yolladım acaba burada mı bir hata yapıyoruz.



  • FTP tarafında Filezilla kullanmayı denemedim ama Windows gezgini ile aşağıdaki formatı kullanarak erişebilmeniz gerekli.
    ftp://username:password@ftpserveradress



  • filezilla zorunlu gibi birşey bizde maalesef



  • peki sunucu adresi kısmına yazdığım formatta bilgilerinizi yazarak erişmeyi dener misiniz.



  • sizin verdiğiniz formatta filezillaya yazdığımda kendi otomatik olarak yazdığım bilgileri gerekli yerlerine atıyor. değişen birşey olmuyor yani



  • sistemde birde opt1 var. wi-fi için kullanmaktayız. proxy bu interfaceyi etkilemiyor. lan'dan gelen 21. port isteklerini bu interfaceye yönlendirebilir miyim acaba?



  • squid custom options kısmının başlangıcına " ignore_expect_100 on; " yazarak çözmüştüm sanırım.

    dağa sonra da sunucu adreslerini whitelist e eklemen gerekebilir.



  • 1. sorunu yani https'lerde takılma açmama olayını squid ayarları içinde "Resolv dns v4 first" özelliğini işaretleyerek çözdüm.

    2. sorun yani filezilla sorununda MuratRaci arkadaşımın önerisi denedim fakat yine olumsuz bir sonuç aldım. Daha sonra filezilla ayarlarından connecti kullanarak bağlantı sağlayabildim. resmi ekledim.

    custom options kısmındaki " ignore_expect_100 on; " kısmını silip tekrar denedim bağlantı sağladı. Fakat ne olur ne olmaz bu komutu squid custom optionsta bıraktım.

    Sonuç olarak sorun çözüldü. Teşekkürler herkese