Как установить нужную версию пакета из ре



  • Добрый день форумчане!
    2.0.1-RELEASE (amd64)
    built on Mon Dec 12 18:16:13 EST 2011
    FreeBSD 8.1-RELEASE-p6
    –------------------------------
    Возникла следующая проблема:
    после обновления пакетов из меню Pakeges возникли ошибки с пакетом squidguard - просто не запускается, не стал разбираться в чем суть (может быть зря),  решил откатится на предыдущий конфиг (сделанный до обновления пакетов, убедился  в редакторе xml, что там прописаны пакеты с версиями предыдущими уже установленным, также посмотрел что https://files.pfsense.org/packages/8/All/ есть предыдущая версия пакетов), восстановил конфиг через меню - Diagnostics-BackUp/Restore - и вот тут началось интересное - пакеты были сначало удалены, потом заново скачаны согласно конфигу, НО скачаны не предыдущие версии как в указаном при восстановлении файле xml, а самые последние на момент восстановления. отсюда вопрос как указать в конфиге нужные мне версии пакетов или же нужно все ручками ставить через pkg_add? и второй вопрос возникший попутно - в репозитарии по указаной выше ссылке имеются все пакеты (snort, freeswich и т.д), но вот через WEB интерфейс они не доступны для установки....почему?



  • и второй вопрос возникший попутно - в репозитарии по указаной выше ссылке имеются все пакеты (snort, freeswich и т.д), но вот через WEB интерфейс они не доступны для установки….почему?

    Может путь к репозиторию другой указать ?

    2.0.1-RELEASE (amd64)
    built on Mon Dec 12 18:16:13 EST 2011
    FreeBSD 8.1-RELEASE-p6

    Я бы слил настройки с pf , сделал скрины важных пунктов и обновился до самой последней. Что мешает Вам ?



  • @werter:

    и второй вопрос возникший попутно - в репозитарии по указаной выше ссылке имеются все пакеты (snort, freeswich и т.д), но вот через WEB интерфейс они не доступны для установки….почему?

    Может путь к репозиторию другой указать ?
    во freebsd он указывается в переменной MASTER_SITE_FREEBSD, в pfsense нашел что-то похожее в /etc/inc/globals.inc, но там не переменная а ввиде условия if с множеством параметров недоступных для моего понимания к сожалению….

    2.0.1-RELEASE (amd64)
    built on Mon Dec 12 18:16:13 EST 2011
    FreeBSD 8.1-RELEASE-p6

    Я бы слил настройки с pf , сделал скрины важных пунктов и обновился до самой последней. Что мешает Вам ?

    я так и поступлю на крайний случай просто уверен, что если обновление пары пакетов повлияло на работоспособность, то обновление одного шлюза повлечет перенастройку и удаленного pfsense 2 соединенного по openvpn (в новой же будет новая версия openvpn), просто была рабочая система без глюков с 2 lan + 2 wan + openvpn site to site + openvpn remote help + squid + squidguard + lightsquid
    а теперь после того как восстановил с конфига где явно прописаны версии пакетов и они есть в репозитарии - pfsense, игнорируя свой же рабочий конфиг решил скачать новые и тем самым "собрал" нерабочую систему
    если можно как-то "запретить" pfsense скачивать новые пакеты, а использовать указаные в конфиге обьясните как, буду очень признателен!