Kabeldeutschland - Pfsense - Fritzbox 7270



  • [Gelöst]
    Guten Tag,

    Ich möchte meine Fritzbox für die Telefonie hinter der Pfsense weiter betreiben.
    Mein Provider ist Kabeldeutschland.
    Hat jemand Erfahrung und könnte diese Posten welche NAT & Rules eingestellt werden müssen, damit die SIP Kommunikation hinter der Pfsense funktioniert?
    Danke

    Einen Alias habe ich angelegt: Fritzbox ^ 192.168.4.99

    Unten ein paar erfolglose Versuche




  • Moderator

    Ich möchte meine Fritzbox für die Telefonie hinter der Pfsense weiter betreiben.
    Mein Provider ist Kabeldeutschland.

    Hallo Keule,

    das sagt leider noch gar nix drüber aus, wie deine Einwahl konfiguriert ist. Bei Kabel baut ja im Normalfall das Kabelmodem oder die Kabel-Fritzbox die Verbindung auf. Wie ist das bei dir?
    Warum bspw. die Telefonie nicht vor der pfSense abwickeln?

    Grüße



  • Hallo,
    meine Fritzbox ist eine 7270 diese Box hat kein Kabelmodem.
    Ich habe die Pfsense direkt am Modem da ich sonst Timing Probleme habe.
    Die öffentliche IP möchte ich unteranderem aus Überwachungsgründen in der Pfsense nutzen. 
    Ich vertraue der Pfsense Firewall mehr als der von AVM.

    Telefonie kann nur über die Fritzbox erfolgen, da der Provider die SIP Daten nicht zu Verfügung stellt.
    Auch das Auslesen der SIP Daten in der Fritzbox ist mit der Version 6.05 nicht mehr möglich da verschlüsselt.
    Ich hoffe, dass sich diese (SIP Daten) Ende des Jahres durch die Gesetzesänderung erhalten werde. Das hilft mir aber jetzt nicht.

    Grüße



  • Wie, Du hast ein KD Modem bekommen (Hitron?) UND eine FB für Telefonie, zusätzlich funktioniert bei Dir der Bridge-Modus am Modem auch noch?
    Unglaublich, wen hast Du bestochen? Bei mir wollen sie nicht mal ein von ihnen selbst kaputt geflashtes Hitron-Modem ersetzen, geschweige denn durch etwas Gescheites austauschen.



  • Hallo Chris,
    ja es gab mal eine Zeit ………….
    Ich habe ein „Echtes“ Modem Von KD. Modell: Thomson THG540K
    Was du da ansprichst (Hitron), ist ein Router mit integriertem Modem.
    Die Fritzbox konnte man zu meiner Zeit noch bei KD kaufen, was ich auch getan habe.
    Als Geschäftskunde gab es auch später noch die Gelegenheit ein „Echtes – Falsches“ Modem zu bekommen (Telefonie - 2*Analog war da integriert) die öffentliche IP wurde aber durchgereicht ohne Bridge- Modus.

    Gruß



  • Telefonie funktioniert.
    Es war der Alias

    -Closed -



  • Hallo keule!

    Könntest du mir den Gefallen tun und mir deine Firewall Regeln/NAT Settings/Alias sowie deine FritzBox Settings zeigen bzw. mit meinen vergleichen?

    Ich habe ein identisches Setup:

    {Internet} <–> [KD-Thomson-Modem]<–>[DHCP][pfSense][192.168.1.1]<–>[192.168.1.2][FirtzBox 7270][192.168.188.1]<–>[DHCP][internes LAN]

    Alles läuft einwandfrei, außer die IP Telefonie von Kabel Deutschland über die FritzBox.

    Problembeschreibung:
    Starte ich sowohl FritzBox als auch pfSense neu, kann ich kurzzeitig vom Handy auf dem VoIP-Festnetz anrufen und umgekehrt.

    Packet Capture direkt nach dem Reboot:
    |Time    | 83.169.182.17                        |
    |        |                  | 31.XXX.XXX.XXX    |                 
    |160.386481|        INVITE SDP (g711A)            |SIP From: <sip:xyzhandynetz@reg143.kabelphone.de:5060;user=phone to:<sip:xyzsipid@reg143.kabelphone.de:5060;user="phone<br">|        |(5060)  –---------------->  (12871)  |
    |160.445498|        100 Trying|                  |SIP Status
    |        |(5060)  <------------------  (12871)  |
    |160.575029|        180 Ringing                  |SIP Status
    |        |(5060)  <------------------  (12871)  |
    |163.398757|        CANCEL    |                  |SIP Request
    |        |(5060)  ------------------>  (12871)  |
    |163.424684|        487 Request Cancelle          |SIP Status
    |        |(5060)  <------------------  (12871)  |
    |163.426730|        200 OK    |                  |SIP Status
    |        |(5060)  <------------------  (12871)  |
    |163.448922|        ACK      |                  |SIP Request
    |        |(5060)  ------------------>  (12871)  |

    Nach einiger Zeit (nicht genau gemessen, ca 30 Minuten, die öffentliche WAN IP von Kabel Deutschland ist immer noch die selbe) plötzlich nicht mehr.
    Beim Versuch vom Festnetz ins Handynetz zu callen, zeigt die FritzBox nur an:
    Internettelefonie mit xyzhandynetz@reg143.kabelphone.de über reg143.kabelphone.de war nicht erfolgreich. Ursache: Forbidden (403)

    In dem Fall zeigt ein Packet Capture:
    |Time    | 31.XXX.XXX.XXX                        |
    |        |                  | 83.169.182.17    |                 
    |3.444116 |        INVITE SDP (g711A g7          |SIP From: <sip:xyzfestnetz@reg143.kabelphone.de to:<sip:xyzhandynetz@reg143.kabelphone.de<br="">|        |(7421)  ------------------>  (5060)  |
    |3.468891 |        100 Trying|                  |SIP Status
    |        |(7421)  <------------------  (5060)  |
    |3.469016 |        403 Forbidden                |SIP Status
    |        |(7421)  <------------------  (5060)  |
    |3.476993 |        ACK      |                  |SIP Request
    |        |(7421)  ------------------>  (5060)  |

    Anbei die Screenshots von meinem Einstellungen.
    Ich habe teilweise doppelte Firewall Regeln... nachdem ich deinen Post gelesen habe, hatte ich noch zwei hinzugefügt...sind eigentlich überflüssig...

    Hast du sonst noch etwas spezielles konfiguriert? Outbound NAT steht bei mir auf Automatisch.

    Vielen Dank und Gruß

    Stefan












    </sip:xyzfestnetz@reg143.kabelphone.de></sip:xyzhandynetz@reg143.kabelphone.de:5060;user=phone>



  • Hallo Stefan,
    anbei zwei weitere Einstellungen:
    Outbound musst du auf manuell stellen und folgende Regel hinzufügen. Wunder dich nicht, wenn du die auf Manuell stellst, gibt es eine Menge automatisch erstellter Regeln zu sehen. (Natürlich solltest du deine IP /Source verwenden (LANPORT1 der Box)

    Den Alias habe ich auch gleich gepostet.
    Wie man die Bilder direkt an die Texte anhängt, werde ich irgend wann auch noch lernen  ;D

    Bei den Fritzboxeinstellungen ist mir deine altenative Konfiguration aufgefallen.
    Hast du wirklich eine alternatives Festnetz?
    Anbei meine Einstellungen in der Box
    Ich hoffe es hilft dir.

    Gruß





    ![Fritzbox eigene Rufnummern 1.PNG](/public/imported_attachments/1/Fritzbox eigene Rufnummern 1.PNG)
    ![Fritzbox eigene Rufnummern 1.PNG_thumb](/public/imported_attachments/1/Fritzbox eigene Rufnummern 1.PNG_thumb)
    ![Fritzbox eigene Rufnummern 2.PNG](/public/imported_attachments/1/Fritzbox eigene Rufnummern 2.PNG)
    ![Fritzbox eigene Rufnummern 2.PNG_thumb](/public/imported_attachments/1/Fritzbox eigene Rufnummern 2.PNG_thumb)



  • Die WAN Rules:




  • Hallo keule,

    vielen Dank für deine Rückmeldung!
    Ich habe nun deine Outbound NAT Setting übernommen sowie die Firewall Regeln angepasst sowie in der Fritzbox die "Portweiterleitung aktiv halten" erneut aktiviert.

    Eigentlich hatte ich das alles schon mal probiert, die Probleme waren aber die gleichen.
    Nach einem Neustart der Fritzbox konnte ich gerade wie sonst auch telefonieren. Nun warte ich erneut einige Minuten und teste dann erneut.
    Melde mich, ob es erfolgreich war.

    Die "Ersatzverbindung" in der Fritzbox habe ich nicht bewusst aktiviert, auch die "Festnetz aktiv" Option nicht…das kommt evt. daher, dass der Router wegen eines Defektes bereits ein mal durch AVM/Kabel Deutschland getauscht wurde (damals hatte ich die pfSense noch nicht)...danach konnte ich anfangs nicht telefonieren und habe wohl u.a. an diesen Einstellungen gespielt...das ist schon etwas länger her :)
    Hatte seit dem nie Probleme mit der Telefonie.

    Also...ich teste mal etwas weiter und melde mich sobald ich Fakten habe.

    Gruß, Stefan



  • Hi keule,

    ich konnte mein Problem nun lösen. Ich habe alle Regeln gelöscht, analog zu deinen eingerichtet und erneut diverse Tests durchgeführt.
    Die Ursache war ein falsches Outbound NAT Regelwerk. Die Reihenfolge der einzelnen Regeln war bei mir falsch!

    Folgende Regeln waren betroffen:
    Interface Source Source Port Destination Destination Port NAT Address NAT Port Static Port
    WAN  192.168.1.2/32 * * * WAN address * YES  
    WAN  192.168.1.0/24 * * * WAN address * NO Auto created rule - LAN to WAN

    Da die Reihenfolge der beiden Regeln vorher andersherum war, wurde kein static Port verwendet, damit kam das SIP irgendwie nicht zurecht.
    So geht es nun (siehe auch NAT Regeln im Screenshot, falls es jemanden interessiert).

    Vielen Dank noch mal für deine Screenshots, das hat mir sehr weitergeholfen.

    Schöne Grüße

    Stefan




  • Hallo Stefan,
    schön, dass es funktioniert.

    Mein nächstes Projekt war ein Teamspeak 3 Server in einer VM - Umgebung in Betrieb zu nehmen und diesen von außen erreichbar zu machen. Als VM benutze ich einen Qnap TS853 Pro auf dem kann man direkt virtuelle Maschinen laufen lassen. Er läuft.
    Sollte jemand wissen wollen warum….. bitte schreiben.
    Gruß
    Jörg