Ugen3.4: <atheros>at usbus3</atheros>



  • Hi all,

    Apologies in advance if this has been answered elsewhere - I tried searching the forum for my error, but without luck.

    I'm very new to this, and I'm trying to setup an old netbook as a wireless access point, that I can use my VPN on (so that any device connecting to the AP automatically goes through the VPN).  The netbook is an Acer Aspire One Happy 2.

    Originally I tried installing Pfsense, and it picked up the NIC as a WAN, but the internal wireless card wasn't detected (I hit 'a' for autodetect, and it couldn't find anything).

    I also have an old USB wireless dongle lying around, that I know supports AP mode, so I thought I'd try that - it's a TP-Link TL-WN721N.  However, when I plug it in to my netbook, I get a message like that in my subject line: ugen3.4: <atheros>at usbus3
    So, my card is clearly detected, but it doesn't look like it's being assigned an interface name (unless I'm misreading).

    From another laptop I can access the Pfsense Web GUI, but when I try to add my card as a new interface, it's not detected. I have tried going to Interfaces > Assign, but there's no way I can see to add a LAN.

    I've tried following some guides online, but I can't see what I'm doing wrong.  Am I missing a step?  Or is my USB wireless incompatible with Pfsense?

    I appreciate any advice you could send my way.

    Thanks in advance.</atheros>



  • ugen is the driver which is loaded when there is no driver.
    So no this card is not detected.
    Why do you think that the internal card wasn't detected?
    Hitting a for autodetect is not really a way to determine if a card works.
    Look at the output of dmesg to see what the internal card is.

    Ignore at the initial setup the wireless part.
    You can assign additional interfaces always after the initial setup under "interfaces –> assign"

    If you don't get any assignable interfaces there then it's probably not detected.



  • If you look here you will see it uses the Atheros AR9271:
    https://wikidevi.com/wiki/TP-LINK_TL-WN721N

    Looking here it is not supported:
    https://wiki.freebsd.org/dev/ath(4)



  • Brilliant, thanks for the replies, guys.

    Back to the drawing board for me…