Disabling Squid cache



  • I want to disable the Squid cache so that the proxy will not do any caching.
    When I go to "Cache Mgmt" and select null for "Hard disk cache system" I cannot save the changes.
    I'm getting these errors:
    The following input errors were detected:

    The field 'Hard disk cache size' is required.
    The field 'Hard disk cache location' is required.
    The field 'Memory cache size' is required.
    The field 'Minimum object size' is required.
    The field 'Maximum object size' is required.
    The field 'Maximum object size in RAM' is required.
    You must enter a valid value for 'harddisk_cache_size'
    You must enter a valid value for 'memory_cache_size'
    You must enter a valid value for 'maximum_object_size'
    You must enter a valid value for 'Minimum object size'

    Does anyone know what is the correct procedure to disable Squid caching?

    Regards.



  • IIRC, you have to set the Hard disk cache size to 0, and set the Hard disk cache system to null.



  • Hi,
    The problem is that without entering values in the other fields (like Hard disk cache location, Memory cache size… etc) I'm unable to save the changes.



  • So give them valid minimal entries, like 1 for memory cache etc.



  • @KOM:

    So give them valid minimal entries, like 1 for memory cache etc.

    This works… been doing it for a while. I need squid for DG, but my experience says that it performs better to disable the cache. At least in my home network.



  • Hi rjcrowder
    Can you tell me what values you are using?

    Regards.