WLAN-Atheros auf ner Soekris - Beta2



  • Moin !

    Ich hab schon Privat ne WRAP mit der Beta 2 ohne Probleme am laufen. WLAN ist realisiert über ne Wistron CM 9 und läuft ohne Probleme.

    Nun habe ich für die Firma eine Soekris Engineering SBC / net4801-50 + lan1621 angeschafft. Auch die läuft mit dem Embedded-Beta2-Image grundlegend sauber. Nun habe ich auch da eine Wistron CM 9 (Atheros AR5213A)+Antennen eingebaut und bekomm die nicht zum laufen. Die Hardware scheint die laut Log erfolgreich erkennt zu haben, aber pfSense bindet diese nicht ein und zeigt mit unter Interface-Status immer Status down an  :(

    Hat einer eine Idee woran das liegen könnte ?
    Hier der komplette Boot-Log:

    
    comBIOS ver. 1.28  20050529  Copyright (C) 2000-2005 Soekris Engineering.
    
    net4801
    
    0128 Mbyte Memory                        CPU Geode 266 Mhz
    
    Pri Mas  Hitachi XX.V.3.7.0.0            LBA 978-8-32  125 Mbyte
    
    Slot   Vend Dev  ClassRev Cmd  Stat CL LT HT  Base1    Base2   Int
    -------------------------------------------------------------------
    0:00:0 1078 0001 06000000 0107 0280 00 00 00 00000000 00000000
    0:06:0 100B 0020 02000000 0107 0290 00 3F 00 0000E101 A0000000 10
    0:07:0 100B 0020 02000000 0107 0290 00 3F 00 0000E201 A0001000 10
    0:08:0 100B 0020 02000000 0107 0290 00 3F 00 0000E301 A0002000 10
    0:10:0 104C AC23 06040002 0107 0210 08 3F 01 00000000 00000000
    0:14:0 168C 0013 02000001 0116 0290 08 3C 00 A0010000 00000000 11
    0:18:2 100B 0502 01018001 0005 0280 00 00 00 00000000 00000000
    0:19:0 0E11 A0F8 0C031008 0117 0280 08 38 00 A0020000 00000000 05
    1:00:0 100B 0020 02000000 0107 0290 00 3F 00 0000D001 A4000000 09
    1:01:0 100B 0020 02000000 0107 0290 00 3F 00 0000D101 A4001000 05
    
     1 Seconds to automatic boot.   Press Ctrl-P for entering Monitor.
     F
    
     /boot/kernel/kernel text=0x49f4f0 data=0x7b774+0x3f658 |
    |
    Hit [Enter] to boot immediately, or any other key for command prompt.
    Booting [/boot/kernel/kernel]...
    Copyright (c) 1992-2006 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD 6.1-PRERELEASE #0: Thu Mar  2 22:07:36 UTC 2006
        sullrich@builder.livebsd.com:/usr/obj.pfSense/usr/src/sys/pfSense_wrap.6
    
    CPU: Geode(TM) Integrated Processor by National Semi (266.65-MHz 586-class CPU)
      Origin = "Geode by NSC"  Id = 0x540  Stepping = 0
      Features=0x808131 <fpu,tsc,msr,cx8,cmov,mmx>real memory  = 134217728 (128 MB)
    avail memory = 121909248 (116 MB)
    wlan: mac acl policy registered
    ath_hal: 0.9.16.16 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    npx0: [FAST]
    npx0: <math processor=""> on motherboard</math>
    npx0: INT 16 interface
    cpu0 on motherboard
    pcib0: <host to="" pci="" bridge="">pcibus 0 on motherboard
    pci0: <pci bus="">on pcib0
    sis0: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xe100-0xe1ff mem 0xa0000000-0xa000
    0fff irq 10 at device 6.0 on pci0
    sis0: Silicon Revision: DP83816A
    miibus0: <mii bus="">on sis0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis0: Ethernet address: 00:00:24:c5:d4:84
    sis1: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xe200-0xe2ff mem 0xa0001000-0xa000
    1fff irq 10 at device 7.0 on pci0
    sis1: Silicon Revision: DP83816A
    miibus1: <mii bus="">on sis1
    ukphy1: <generic ieee="" 802.3u="" media="" interface="">on miibus1
    ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis1: Ethernet address: 00:00:24:c5:d4:85
    sis2: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xe300-0xe3ff mem 0xa0002000-0xa000
    2fff irq 10 at device 8.0 on pci0
    sis2: Silicon Revision: DP83816A
    miibus2: <mii bus="">on sis2
    ukphy2: <generic ieee="" 802.3u="" media="" interface="">on miibus2
    ukphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis2: Ethernet address: 00:00:24:c5:d4:86
    pcib1: <pci-pci bridge="">at device 10.0 on pci0
    pci1: <pci bus="">on pcib1
    sis3: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xd000-0xd0ff mem 0xa4000000-0xa400
    0fff irq 9 at device 0.0 on pci1
    sis3: Silicon Revision: DP83816A
    miibus3: <mii bus="">on sis3
    ukphy3: <generic ieee="" 802.3u="" media="" interface="">on miibus3
    ukphy3:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis3: Ethernet address: 00:00:24:c4:d8:0c
    sis4: <natsemi 10="" dp8381[56]="" 100basetx="">port 0xd100-0xd1ff mem 0xa4001000-0xa400
    1fff irq 5 at device 1.0 on pci1
    sis4: Silicon Revision: DP83816A
    miibus4: <mii bus="">on sis4
    ukphy4: <generic ieee="" 802.3u="" media="" interface="">on miibus4
    ukphy4:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis4: Ethernet address: 00:00:24:c4:d8:0d
    ath0: <atheros 5212="">mem 0xa0010000-0xa001ffff irq 11 at device 14.0 on pci0
    ath0: Ethernet address: 00:0b:6b:4c:a8:2d
    ath0: mac 5.9 phy 4.3 radio 3.6
    Geode GPIO@ = 6100
    Geode Soekris net4801 comBIOS ver. 1.28 20050529 Copyright (C) 2000-2005
    isab0: <pci-isa bridge="">port 0x6100-0x613f,0x6200-0x623f at device 18.0 on pci0
    isa0: <isa bus="">on isab0
    pci0: <bridge>at device 18.1 (no driver attached)
    atapci0: <national geode="" sc1100="" ata33="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0
    x177,0x376,0xe000-0xe00f at device 18.2 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata1: <ata 1="" channel="">on atapci0
    Geode CBA@ 0x6000
    Geode rev: 06 03
    Timecounter "Geode" frequency 27000000 Hz quality 1000
    pci0: <bridge>at device 18.5 (no driver attached)
    ohci0: <ohci (generic)="" usb="" controller="">mem 0xa0020000-0xa0020fff irq 5 at device
     19.0 on pci0
    ohci0: [GIANT-LOCKED]
    usb0: OHCI version 1.0, legacy support
    usb0: <ohci (generic)="" usb="" controller="">on ohci0
    usb0: USB revision 1.0
    uhub0: (0x0e11) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub0: 3 ports with 3 removable, self powered
    pmtimer0 on isa0
    orm0: <isa option="" rom="">at iomem 0xc8000-0xd0fff on isa0
    ppc0: parallel port not found.
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0
    sio0: type 16550A, console
    sio1 at port 0x2f8-0x2ff irq 3 on isa0
    sio1: type 16550A
    Timecounters tick every 10.000 msec
    Fast IPsec: Initialized Security Association Processing.
    ad0: FAILURE - SETFEATURES SET TRANSFER MODE status=51 <ready,dsc,error>error=4<
    ABORTED>
    ad0: 122MB <hitachi xx.v.3.7.0.0="" rev="" 0.00="">at ata0-master BIOSPIO
    GEOM_LABEL: Label for provider ad0a is ufs/pfSense.
    GEOM_LABEL: Label for provider ad0d is ufs/pfSenseCfg.
    Trying to mount root from ufs:/dev/ufs/pfSense
         ___
     ___/ f \
    / p \___/ Sense
    \___/   \
        \___/
    
    Welcome to pfSense BETA-2 on the 'embedded' platform...
    
    Setting up embedded specific environment... done.
    Mounting filesystems... done.
    Starting device manager (devd)... done.
    Loading configuration... done.
    Updating configuration... done.
    Cleaning backup cache... done.
    Setting up extended sysctls... done.
    Syncing user passwords... done.
    Starting Secure Shell Services... done.
    Setting timezone... done.
    Starting syslog... done.
    Configuring LAN interface... done.
    Configuring WAN interface... done.
    Configuring OPT interfaces... done.
    Configuring CARP interfaces...done.
    Configuring firewall...  aliases  rules  filtering done.
    Starting webConfigurator... done.
    Starting DNS forwarder... done.
    Starting DHCP service... done.
    Starting NTP client... done.
    Setting up microcode and tx/rx offloading... done.
    Starting FTP helpers... done.
    Starting DHCP service... done.
    Starting CRON... done.
    Syncing packages...
    Executing rc.d items...
     Starting /usr/local/etc/rc.d/*.sh...done.
    Bootup complete
    
    FreeBSD/i386 (firewall.firewall.local) (console)
    
    *** Welcome to pfSense BETA-2-embedded on firewall ***
    
      LAN                      ->   sis0    ->      192.168.10.254
      WAN                      ->   sis1    ->      NONE(PPPoE)
      OPT1(WLAN)               ->   ath0    ->      NONE
    
     pfSense console setup
    ***********************
     0)  Logout (SSH only)
     1)  Assign Interfaces
     2)  Set LAN IP address
     3)  Reset webGUI password
     4)  Reset to factory defaults
     5)  Reboot system
     6)  Halt system
     7)  Ping host
     8)  Shell
     9)  PFtop
    10)  Traffic Logs
    11)  Restart webConfigurator
    
    Enter an option:</hitachi></ready,dsc,error></isa></ohci></ohci></bridge></ata></ata></national></bridge></isa></pci-isa></atheros></generic></mii></natsemi></generic></mii></natsemi></pci></pci-pci></generic></mii></natsemi></generic></mii></natsemi></generic></mii></natsemi></pci></host></fpu,tsc,msr,cx8,cmov,mmx> 
    


  • Entferne testweise mal die lan1621. Geht die Atheros dann? Wenn ja hat Dein Netzeil vmtl. zu wenig Leistung. Die Ports von der lan1621 scheinen momentan sowieso nicht zugeordnet zu sein.


Locked