PBUCON



  • I help admin a COD4 server and I can't get PFsense to pass the pbucon console info to my pc. I set a port forward rule on WAN from the server ip UDP port 28960 to 192.168.11.252 port 28880. It worked on my Linksys router and it also worked on Smoothwall. Any idea why the same rule will not work on PFsense?



  • Maybe you missconfigured something?
    Could you show screenshots of your rules?





  • You have as source 28960.
    Meaning your client connecting will have to use 28960 as source port which is VERY unlikely ;)

    Set it to * and it should work.



  • Ok, changed it to * and still no joy. Maybe I need a NAT rule?

    Firewall log shows this being blocked: Apr 19 11:33:39  WAN  72.232..:28960  75...*:28880  UDP



  • Yes delete your rule and try with nat, check your windows firewall too



  • Show us your portfrward as well. From your first post it sounds like you are doing port translation as well?



  • I should mention that I am on DSL with the PPPoe on the modem with it set to pass the public ip to PFsense.
    Windows firewall is off on the pc.



  • Try with TCP/UDP



  • Deleted rules and tried tcp/udp no go.



  • @redpanther:

    Firewall log shows this being blocked: Apr 19 11:33:39  WAN  72.232..:28960  75...*:28880  UDP

    Your client tries to connect to port 28880 but the port you opened to the public is 28960. Are you sure you need that port translation? I would just use the same internal and external port. Makes things a bit easier.



  • @hoba:

    Your client tries to connect to port 28880 but the port you opened to the public is 28960. Are you sure you need that port translation? I would just use the same internal and external port. Makes things a bit easier.

    Tried the same port 28880 internal and external.



  • Delete everything (firewallrule and NAT-rule) and restart from scratch. It's dead simple! Create the nat rule and leave the autocreate firewallrule box checked. It simply works. You are definately doing things wrong here. If that doesn't work it's something in front of you or at the client. Seriously.



  • Re-did it over and over. Even rebooted after I made changes changes and it will not work.  ??? I seem to recall it wouldn't work with Smoothwall till I Did a forward from the internal portforwarding tab. I can't figure out what the difference is that it won't work with PFsense. No changes were made other than switching the hard drives in the firewall box.



  • Are you testing this with a client sitting at your wan? If you come from lan you will need system>advanced, disable natreflection unchecked (very bottom of that page).



  • I changed the Hard drive out to Smoothwall and it works like a charm. Same modem, same hardware, same configuration,  just changed the drive out.
    The RconMax client software is on my laptop on my LAN and I have no issues connecting through SW and recieving the pbucon console info from the server. Unfortunately I don't want to use SW, I want to use PFsense. I even tried the disable nat reflection under advanced.



  • It should work with natreflection. Guess you should have reset states after enabling it (diagnostics>states, reset states). Try if it works after rebooting. It should work coming from wan already. Do you have the need to access that service through the public IP from lan?



  • @hoba:

    It should work with natreflection. Guess you should have reset states after enabling it (diagnostics>states, reset states). Try if it works after rebooting. It should work coming from wan already. Do you have the need to access that service through the public IP from lan?

    Rebooting didn't work. Yes I must connect from the Lan side through the WAN. What I am doing is connecting to a remote game server that I admin. The RconMax software on my pc can connect to the server ok through PFsense but the PBUCON console part of it cannot stream the PB info from the server.  Basically the software is telling me that the port 28880 is not forwarded to my pc when it obviously is in the rules.



  • Just for fun I downloaded the latest live iso and used it with another machine and entered the rule, it did not work either.  :'(


Locked