Wireless AP on serperate subnet - can't ping hostnames

  • Hey all - running Pfsense 1.2 and I have three NICs, they are WAN, LAN, & OPT1 (WLAN) & the OPT1 is a cisco wireless card.  I have it setup on its own subnet and my wireless client can authenticate and get an IP and surf the net fine.

    LAN = 172.25.47.x
    WLAN = 172.25.48.x

    my only problem is that my WLAN clients can't ping my LAN clients by their host name, but if I plug them into my LAN subnet, they can ping each other just fine by name.  When my WLAN clients are connected to the WLAN subnet, they can ping the LAN clients by IP just fine, but name resolution is not making it across the subnets.  Is this normal, or should I just go back to bridging?

  • tick DNS forwarder -> Register DHCP leases in DNS forwarder and see if it helps

  • I already had that option ticked before I posted, it was no help… any other ideas?  Thanks

  • I just did a test on a test-network.

    It just works.


    Both checkboxes:
    "Register DHCP static mappings in DNS forwarder"
    "Register DHCP leases in DNS forwarder"
    are checked.

    I can access a server on the LAN from WAN by using its name.

    If you are on the WLAN-interface and do a ipconfig/all: what "Connection-specific DNS Suffix" do you get? Is it the same as you set on pfSense: "System" –> "General Setup" --> "Domain" ?

    Do your clients on the WLAN-interface have as DNS server the pfSense as primary server?

  • Hey- thanks for your help… my connection-specific DNS suffix on my WLAN client matches with what I have in my PFsense System --> general setup --> domain.  When I do an ipconfig /all, my DNS servers that I get assigned to me are from my ISP and neither one is my PFsense box.  Should the primary DNS server be my PFsense box?

    thanks again!

  • Think about if for a second…
    How is your ISPs DNS supposed to know any name in your private network?

  • your right, it can't at all - would it work if I just left the DNS servers blank in the DHCP WLAN page and them PFsense assign them to the clients itself, or should I just put the one entry for my PFsense box in box one for the DNS servers?

  • Read the config page.

    NOTE: leave blank to use the system default DNS servers - this interface's IP if DNS forwarder is enabled, otherwise the servers configured on the General page.

Log in to reply