Proxy Filter: sgerror.php



  • pfSense 2.2.2 x64
    squid3 0.2.8
    squidGuard 1.9.14

    Proxy filtering is working - things are being blocked.  However I'm not getting the correct blocked page instead I get a squid error message.  Proxy is in transparent mode.  I've seen lots of how-tos
    that show entering values into fields where if it's left blank the default values are applied (Proxy Server, ACLs, Allowed Subnets I entered my local subnet even though it says " Note that the proxy interface subnet is already an allowed subnet").  So what are the right things to enter?  Do I need to enter default values?

    Either way, I seem to have a problem and the proxy filter can't display the blocking page.  The attached screen shots are only of the values I have changed - everything else are at default.











  • Eureka!

    I use HTTPS to manage the pfSense GUI.  When I disable HTTPS for management I get the correct blocking message and the sgerror.php "Zero Sized Reply" error goes away.

    So… now that I know that, how do I fix it so that I can still use HTTPS for the management GUI and keep the blocking message working?

    thx.



  • Put your error page on a different HTTP server.





  • Hello. I myself have the same problem wit the block page not displaying properly and it does when i switch the admin interface to use http instead https. Any fix for this yet?