Firefox downthemall segments issue through proxy



  • Hi all, have an issue with downthemall segments going through the proxy (wpad).

    Some sites work and I can download from multiple segments
    Example
    http://support.lenovo.com/us/en/products/laptops-and-netbooks/100-series/100-14iby/downloads/DS102760

    But other sites I can only download through 1 segments
    Example
    http://www.ubuntu.com/download/desktop

    But if I do not go through the proxy then there is no more issues and I can download from multiple segments with any site.

    Anyone have any ideas?



  • Segments? What do you mean by segments??  I went to the webpage you linked to and downloaded the file.  No problem.



  • Hi KOM, in this example downthemall has cut the download into 4 segments.

    With the first example link i gave downthemall was able to download from multiple segments however some sites are not able to like the second link. But if I bypass the proxy then both links are able to download form multiple segments correctly.



  • Wow, I haven't seen a download manager since the 2000's and GetRight.  I don't have anything to suggest other than to make sure you're running squid3.  Squid2 is old enough that it may have problems with the advanced features of some web servers and updated HTTP spec.



  • Hi KOM, I use downthemall for faster downloads (give it a try), I am already using squid3, i do not know if it is a squid issue or a downthemall issue, anyone else using downthemall through a proxy experiencing this issue?

    Please note:
    When not going through the proxy there is no problem.

    When going through the proxy some sites can only download through 1 segment.



  • Finally found a fix for this

    changed
    Firewall: Rules LAN FROM

    IPv4 *	LAN NET	*	*	*	*	none	 	Default allow LAN to any rule 	
    IPv6 *	LAN NET	*	*	*	*	none	 	Default allow LAN IPv6 to any rule 
    

    TO

    IPv4 *	*	*	*	*	*	none	 	Default allow LAN to any rule 	
    IPv6 *	*	*	*	*	*	none	 	Default allow LAN IPv6 to any rule 
    


  • While I'm glad you got it working, I'm not quite sure how that rule change would affect anything.  Assuming you're already on LAN, LAN net and * are effectively the same thing.



  • I do not know ever (might be something to do with the way the segments connect), however it works and I have been trying to find away to fix this for a while.

    Hope this helps others



  • arr, made an update in my wpad which took out the proxy, that's why it worked :(



  • I didn't think that change would make any difference.  Btw, best practice usually calls for blocking 80/443 when using a proxy so that users can't get around it by themselves.



  • I am having the same Problem.
    I am using Downthemall because i have 3 Wan, to geht fullspeeddownloads.
    Without Proxy its working, with proxy he is using all line and than after a few second only one.

    This was working for me with older Pfsense squid version.I use this setup for quite some Time now.
    At the moment i have not really the Timeto make testinstalls with older versions.

    MFG Alex



  • Ok i have found my old HDD(changed them for an ssd) Put them in and voila all working.
    Running pfsense 2.15  and squid3-dev 3.3.10 pkg 2.2.8.

    Mfg Alex



  • Hm i updated the old setup to all recent 2.2.4 and latest squid and its still working.
    The other setup was a new from scratch i made with 2.2 changes.

    Maybe on weekend i have time to make an brandnew install and check.



  • So did you get it working? I found that downthemall works (uses all segments) on some sites but not others when going through the proxy.

    To test try downloading the latest ubuntu (which I have found to have the segments issue when going through squid).



  • Hi all I am bumping up this topic again because I made a few observations.

    I have determined that Squid has an issue with multi segment downloading/Multithread downloading.
    Testing with downthemall for firefox and metalink for chrome downloading a test file http://mirror.internode.on.net/pub/test/
    When port 80 and 443 are blocked and all traffic is going through squid the download is limited to 1 segment resulting in slow download speed.

    However when not going through squid then the segments are not limited to 1, resulting in being able to download 10x faster (because now I can connect to 10 segements).

    I have also found that some software update programs which use multi segment downloading/Multithread downloading become slow at downloading.

    Now this is the strange part, squid does support multi segment downloading/Multithread downloading, when downloading from youtube you are able to connect to multi segments and get full bandwidth.

    So I guest the big question is is this a pfsense squid package issue or a squid-cache.org issue? Where should I post this bug/issue?


Log in to reply