CP partially operational after v2.2.2 upgrade



  • Hello guys,

    I'm new into the forum. I've been searching for this error for a while, basically Captive Portal is partially operational after the v2.2.2 upgrade.
    Scenario: PfSense v2.1.5 upgraded to v2.2.2. Upgrade was correct, but unreacheable via SSH/Web GUI after this process. Unit came back after a manual power cycle. My current setup includes voucher rolls + MAC pass thru auth, both methods were working before the upgrade.
    Checking for related topics, I've found the following error in the auth log:

    XXX logportalauth[36185]: Zone: XXX_sales - Error during table XXX_sales creation. Error message: file is encrypted or is not a database
    

    Found a similar behaviour in an external website, indicating that stopping the CP service, saving/removing the captiveportalxxx.db file and starting the service again would fix the problem. I've completed this process but CP is still not working. Some MAC auth users have been reporting access issues, and voucher access seems to not work. Users goes back to captive portal auth page after insert their voucher.

    Found this topic as well: https://forum.pfsense.org/index.php?topic=87864.0, no clear solution stated.

    Any thoughts? Thanks a lot for your feedback



  • Hi, sounds like you may have done an in-place upgrade, is this correct? And - hopefully - you took a full backup of your config before performing the upgrade? And you removed all/any packages before upgrading?

    If this true in all cases, then the answer may be to perform a fresh installation of v2.2.2 and then restore your backup once the install has completed. Above all you should always - always - take a full backup of your firewall before making any significant changes. Particularly upgrades.



  • @muswellhillbilly:

    If this true in all cases, then the answer may be to perform a fresh installation of v2.2.2 and then restore your backup once the install has completed. Above all you should always - always - take a full backup of your firewall before making any significant changes. Particularly upgrades.

    Hello muswellhillbilly, thanks for your reply. I was able to resolve this issue after a fresh install of v2.1.5 + config.xml restore. I'll keep this version running until the v2.2.2 fix is released!

    Thanks,

    Facundo


  • Rebel Alliance Developer Netgate

    I believe this happens on upgrade if the CP .db files  in /var/db didn't get reset. On 2.1.x they were in SQLite 2.x format and on pfSense 2.2+ it's SQLite 3.


Log in to reply