Cannot Wake On Lan from OpenVPN



  • Hi!

    I'm trying to wake a machine on my LAN trough a OpenVPN tunnel.
    My machine can be woke up using the PfSense WOL interface, but I do not want to give admin password to my users (who needs to remote acess their shut-down machines from home).
    Many command-line applications exist, and they do the trick from inside the LAN, but when used on a OpenVPN tunnel it simply fails. The packet does not seem to traverse.

    Is their an easy way for me to wake my machine from VPN without having to run a program on a Lan machine?

    Thanks!
    -Jay2



  • Wake on lan won't work for routed subnets. You have to be in the same layer2 subnet. Version 1.3 will have a user manager where you can add webgui users with specific rights (for example only access to the wake on lan page). This way you could allow your users to wake up the machines from the webgui.

    Just had a weird thought but maybe it will work:

    • enable the captive portal at an interface that you don't use (could be even a vlan).
    • generate and upload a php page that has the remote machines listed and that uses the php script to wake up the clients (just copied a link from a client that I created in my webgui):
    
    services_wol.php?mac=01:23:45:67:89:00&if=lan
    
    

    "mac" is obviously the macadress of the client and "if" the interface name that the client sits behind. You also could try to just embedd the code of services_wol.php in your page.

    • users can access the page by going to http://<captive-portal-interface-ip>:8000. You can make that easier by adding some nice dns name like "http://caffeine:8000"  ;)

    For this to work make sure that you route the traffic to the captive portal IP through the tunnel as well.

    Btw, if you get this working please provide the code of the php page that you use for your captive portal  :)</captive-portal-interface-ip>


Locked