Need help to disable Squid3 cache



  • HI,

    I might be doing something wrong, what I did is editing the "/usr/pbi/squid-amd64/local/etc/squid/squid.conf", thats the only place I can found squid.conf, commented the line 'cache allow all', and replace it with "cache deny all", and save.  but once stop and start Squid3,  the new added line is gone, and 'cache allow all' is there, uncommented. so, Where is the place to prevent Squid3 from caching.

    Thanks.



  • Set the Hard disk cache size to 0 (or 1 if it doesn't allow 0) and the Hard disk cache system to null.



  • @KOM:

    Set the Hard disk cache size to 0 (or 1 if it doesn't allow 0) and the Hard disk cache system to null.

    Thanks. it did trick.



  • Hmmm,  Its still writing something to the disk although cache is disabled whenever I open a webpage from browser, and it stops HDD writing until I switch to another site.



  • Just because you disabled caching doesn't mean all disk writes just magically stop.  Do you have logging enabled, for instance?



  • @KOM:

    Just because you disabled caching doesn't mean all disk writes just magically stop.  Do you have logging enabled, for instance?

    I have Snort, pfBlockerNg installed, having logging enabled. But from Status->System Logs->Settings, I "Disable writing log files to the local disk". but still I saw a lots of write intensive activities to the HDD when switching between web pages until the pages loading were done. Just like it wrote caches to the disk, but the /var/squild/cache folder is empty though.  Might be Squid3 AntiVirus thing?  Don't see any reason why snort/pfblockerng would do something about that. BTW, I also disable the RRD graphing backend already.

    P.S. I'm going to replace the HDD with a SSD, but these kind of write intensive activities made me hesitate now.



  • After running top -a/m,  found that mostly due to the /usr/local/sbin/clamd or c-icap, that having WRITE activities:

    /usr/local/sbin/clamd

    /usr/pbi/squid-amd64/local/bin/c-icap -f /usr/pbi/squid-amd64/local/etc/c-icap/c-icap.conf

    so the question is how to avoid?  Thanks.



  • No idea, sorry.  I don't run ClamAV.  If there isn't a config setting for it, or a trick like setting the logfile name to blank, then perhaps it can't be done.



  • End up removing the whole package,  the only reason to use it at home was the Anti-Virus, but it keeps wriite intensive activities to HDD, not worth it.


Log in to reply