Messaje Error OpenVPN



  • Hi!
    I want to connect over the WAN, but I get an error, have the following configurations and do not know if it's okay. I am new at this (student)

    Firewall Rules WAN:

    Firewall Rules OpenVPN:

    Rules Server VPN:

    Ip Server:

    PfSense Configuration:

    Messaje Error:

    Thanks for ur support.

    Regards



  • First problem with your setup: your LAN and WAN are on the same subnet 192.168.1.0/24 this will not work.

    I assume your WAN interface is connected to a modem/router that is handing out an internal address on 192.168.1.0/24.

    If you stick with this configuration you're going to be doing a double NAT, not a simple setup.

    The first thing you have to do is change your LAN subnet to 192.168.33.0/24 or some thing higher.
    Try to never use 192.168.0.0/24 or 192.168.1.0/ for LAN as they are often the default of some other device (as you see with your ISP's modem/router).

    The second issue is to try and get your ISP's modem/router into bridge mode so that it acts only as a modem.
    This will give your WAN interface a public IP and put your pfSense box on the internet.

    If you can't bridge your internet connection you'll have to read up on double NAT and see what solution will work in your situation.



  • @divsys:

    First problem with your setup: your LAN and WAN are on the same subnet 192.168.1.0/24 this will not work.

    I assume your WAN interface is connected to a modem/router that is handing out an internal address on 192.168.1.0/24.

    If you stick with this configuration you're going to be doing a double NAT, not a simple setup.

    The first thing you have to do is change your LAN subnet to 192.168.33.0/24 or some thing higher.
    Try to never use 192.168.0.0/24 or 192.168.1.0/ for LAN as they are often the default of some other device (as you see with your ISP's modem/router).

    The second issue is to try and get your ISP's modem/router into bridge mode so that it acts only as a modem.
    This will give your WAN interface a public IP and put your pfSense box on the internet.

    If you can't bridge your internet connection you'll have to read up on double NAT and see what solution will work in your situation.

    Hi, thanks for responding.
    The settings that tell me that they can not be on the same subnet also had told me, but as a test of VMware virtualization have been told that there is no problem.
    Changing the LAN IP was difficult because I do I have configured the 2 servers and all clients + 2 services.
    If no alternative solution I have to.
    The bridge so I did not understand very well, I have it in vmnet2 (NAT)

    Thanks



  • I'm not expert enough on VM setups to pinpoint the issue with your setup.

    Perhaps someone else will chime in or try in the VM section: https://forum.pfsense.org/index.php?board=37.0


Log in to reply