Diagnostics - Backup: someone broke it


  • Banned

    After the latest batch of htmlspecialchars and whatnot fixes, the checkboxes are not honored! Like,

    • I have the "Do not backup RRD data (NOTE: RRD Data can consume 4+ megabytes of config.xml space!)" checkbox pre-ticked, but the downloaded config.xml contains all the RRD data.
    • When I untick it, I get the RRD data twice, as a bonus!

    Also seeing some other weird issues elsewhere, TBC.

    EDIT: Filed a bug - https://redmine.pfsense.org/issues/4773


  • Rebel Alliance Developer Netgate

    I replied back on the ticket. diag_backup.php wasn't touched in that round of updates, and hasn't been changed at all since before 2.2.2 shipped.

    I can't reproduce that on a current snapshot either. Are you certain that config.xml was restored from the GUI using diag_backup.php?

    If it were copied into place manually or done any other way other than diag_backup.php then the code to restore the RRD data and unset it from the config wouldn't have been triggered.

    If there are other issues, I'd like to hear about them, are they in other threads? I haven't been monitoring the forum closely the last few days.


  • Banned

    @jimp:

    Are you certain that config.xml was restored from the GUI using diag_backup.php?

    I'm pretty sure I have not more than 2-3 beers before restoring the config. :D

    @jimp:

    If there are other issues, I'd like to hear about them, are they in other threads? I haven't been monitoring the forum closely the last few days.

    Well, I'm trying to get in touch with the pfBlockerNG author to see what he thinks; seems he's AWOL at the moment.  ;D Basically, I have a base64-encoded exclusion list in the config that gets ignored all of a sudden. The only change there being a gitsync a couple of days ago.


Log in to reply