Squid3+ Squidguard3 running but not working…



  • Hello Guys,

    I have 2 packaged intalled on my pfsense version 2.1.5
    SQUID3 3.1.20 pkg 2.1.2
    squidGuard-squid3 1.4_4 pkg v.1.9.12

    I configured the proxy filter to use blacklist and I download from pfsense the list froM:
    http://www.shallalist.de/Downloads/shallalist.tar.gz
    Target:
    !blk_BL_hacking !blk_BL_porn !blk_BL_spyware all

    but.. is same as NOTHING…
    both services are running, and doing nothing:
    Proxy server real time no data (screenshot attached)
    Proxy filter Blocked No data (screenshot)

    Help Please!
    Ideas??










  • Can you confirm that squid is working first?  Do you have data in /var/squid/logs/access.log?



  • try squidGuard package instead of squidGuard-squid3 package.

    I configured the proxy filter to use blacklist and I download from pfsense the list froM:

    But how is squid configured, are you using a transparent proxy, non transparent proxy or wpad?



  • @KOM:

    Can you confirm that squid is working first?  Do you have data in /var/squid/logs/access.log?

    HI!!
    thanks for your reply,

    both was working first, them after 1, 2 days they stop working and I couldn't fix it over since..

    Cache.log size 4mb

    last entries are:

    015-06-24 00:00:03 [73931] loading dbfile /var/db/squidGuard/blk_BL_webradio/domains.db
    2015-06-24 00:00:03 [73931] init urllist /var/db/squidGuard/blk_BL_webradio/urls
    2015-06-24 00:00:03 [73931] loading dbfile /var/db/squidGuard/blk_BL_webradio/urls.db
    2015-06-24 00:00:03 [73931] init domainlist /var/db/squidGuard/blk_BL_webtv/domains
    2015-06-24 00:00:03 [73931] loading dbfile /var/db/squidGuard/blk_BL_webtv/domains.db
    2015-06-24 00:00:03 [73931] init urllist /var/db/squidGuard/blk_BL_webtv/urls
    2015-06-24 00:00:03 [73931] loading dbfile /var/db/squidGuard/blk_BL_webtv/urls.db
    2015/06/24 09:27:08| WARNING: Unused ICP version 96 received from 219.142.89.110:7469
    2015/06/24 09:27:09| WARNING: Unused ICP version 97 received from 219.142.89.110:7469
    2015/06/24 09:27:10| WARNING: Unused ICP version 98 received from 219.142.89.110:7469
    2015/06/24 09:27:12| WARNING: Unused ICP version -80 received from 202.106.80.110:21237
    2015/06/24 09:27:12| WARNING: Unused ICP version -79 received from 202.106.80.110:21237
    2015/06/24 09:27:13| WARNING: Unused ICP version -78 received from 202.106.80.110:21237

    access.log 0kb..

    not good..



  • @aGeekHere:

    try squidGuard package instead of squidGuard-squid3 package.

    I configured the proxy filter to use blacklist and I download from pfsense the list froM:

    But how is squid configured, are you using a transparent proxy, non transparent proxy or wpad?

    I believe if I use Squid3 I should go with Squidguard3.. is that not correct???

    I am using in Transparent proxy… works ok for like 24hs and after that the " Blocked " log shows " No data" ...



  • It's squid that is having the problem.  You should have something in access.log.  All web access is logged there.  SO, fix squid and then try again.  I would uninstall squidguard then squid, then install just squid and get it configured and working.  Then add squidguard.

    Is this running on a PC or an appliance like an ALIX?



  • @KOM:

    It's squid that is having the problem.  You should have something in access.log.  All web access is logged there.  SO, fix squid and then try again.  I would uninstall squidguard then squid, then install just squid and get it configured and working.  Then add squidguard.

    Is this running on a PC or an appliance like an ALIX?

    its running on Soekris, wich is an appliance.
    I will try to remove both, delete the directory and then install them again.

    thanks!



  • Soekris

    I'm not familiar with that particular unit, but some of the units have limited RAM which makes them not suitable for things like squid caching and squidguard blacklists.



  • @KOM:

    Soekris

    I'm not familiar with that particular unit, but some of the units have limited RAM which makes them not suitable for things like squid caching and squidguard blacklists.

    this appliance has a 2 cpu intel 1.6mhz and 2gb I think should be enough also the memory is running at only 50% CPU it's about 66%.

    in order to Remove Squid+ Squidguard… can someone please tell me ALL the directories that I should remove in order to get it Completely out of the system.

    Thanks in advance!!



  • I don't remember them all but it's been done here several times.  Search the forums for "squid clear|clean|remove|fresh" etc.


Log in to reply