Snort time off after 2.2.3 update



  • Updated to pfsense 2.2.3 and noticed after the update the alert times reported by Snort are showing not the local time but the GMT time for the alerts.

    How can I fix this?


  • Rebel Alliance Developer Netgate

    That sort of issue is typically a time zone problem. Which specific time zone do you have selected?

    If you are not already using one, try a geographically named zone (e.g. America/New York)



  • @jimp:

    That sort of issue is typically a time zone problem. Which specific time zone do you have selected?

    If you are not already using one, try a geographically named zone (e.g. America/New York)

    for some reason, after upgrade to 2.2.3 from 2.2.2, time zone defaults to the first item of the drop downs,  so I got the same issue,  It seemed that it couldn't find the setting that was set in 2.2.2 (was Canada/Eastern time zone)



  • Thanks
    Fixed For some reason the upgrade changed the time zone.  The strange part was that PFsense and pfblockerng was showing the correct time on the dashboard but Snort was not.  The timezone I'm using is America/Moncton


  • Rebel Alliance Developer Netgate

    What probably happened is that when we updated the time zone data, your old named zone was moved/renamed/deleted and it defaulted since it didn't know what else to do.

    We don't make those edits ourselves, however. We get that data from FreeBSD so it must have changed upstream somewhere.


Log in to reply