Squid is suddenly blocking websites @ 2.2.3



  • Hi!

    Just upgraded to 2.2.3, and Squid started to block certain websites:

     While trying to process the request:
    
    GET /user/malajen HTTP/1.1
    Host: www.last.fm
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: sv-SE,sv;q=0.8,en-US;q=0.5,en;q=0.3
    Accept-Encoding: gzip, deflate
    DNT: 1
    Cookie: AnonSession=7a53eb58c9035b50fbad1079b6e88add-35b3852c354c11ff20e1be8f7aab8d95359d3c05674340711ebb2fbc65cfb959
    Connection: keep-alive
    
    The following error was encountered:
    
        Invalid Request 
    
    Some aspect of the HTTP Request is invalid. Possible problems:
    
        Missing or unknown request method
        Missing URL
        Missing HTTP Identifier (HTTP/1.0)
        Request is too large
        Content-Length missing for POST or PUT requests
        Illegal character in hostname; underscores are not allowed 
    

    This is what happends Transparent proxy is checked.

    Any idea how to fix this?



  • Restart the service or reboot the server.  If that doesn't work, you can uninstall and then reinstall the package.  If that doesn't work then you can try to recreate the cache structure by running

    rm -rf /var/squid/cache/*

    and then

    squid -z to recreate the cache structure.


  • Banned

    Squis login page says : Use alternate DNS-servers for the proxy-server

    Type 172.0.0.1 and hit save.

    That will do it. (did for me with the same errors).



  • I had the same issue when I upgraded from 2.2.1 to 2.2.2 (see https://forum.pfsense.org/index.php?topic=92564) so reverted back to 2.2.1. I upgraded to 2.2.3 yesterday and had the same issue. I removed the squid package, installed the squid3 package and the issue has been resolved.


  • Banned

    Yes. I dumped Squid completely….. it just sucks.



  • I think that this too has to deal with the mount option in /etc/fstab. Change 'sync' to 'nosync'. Save and then reboot the box.

    Also, as stated above use Squid3.