Squid blocks HTTP Traffic



  • Hello guys and forgive my poor english,
    I installed pfSense with Squid, lightSquid and FreeRadius. I enabled CaptivePortal on my LAN interface with authentification through the Radius server. I checked the box to enable transparent proxy on Squid settings and the box to enable users to connect to my interface. With this configuration i can't access to sites using port 80 but I can access to sites using https like twitter or facebook. If i uncheck the two boxes in the Squid settings I can browse the web normally. Can someone help me to improve my configuration and thanx to all.



  • what is you configure the pfsense server IP as your proxy server on your web browser do you have the same issue?



  • I need the captive portal enabled. It's better for authentification of users who don't have any idea of computer.


Log in to reply