Squid-2.7.9_3-amd64 package installation aborted



  • Beginning package installation for squid .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squid and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/amd64/8/All/squid-2.7.9_3-amd64.pbi ...  (extracting)
    Verifying Checksum...SKIP_ARCHLINES: 59
    Archive checksum: 186a49198cc95b92e579fab2127ce3611fbcccbd771af6f231dfabd2b7a26e04
    Saved checksum: 607528f8a6feae906844ac55205788ecdb92f097085409a98d25b19cf23c4606
    pbi_add: /tmp/apkg_squid-2.7.9_3-amd64.pbi failed checksum, the archive may be corrupt.
    of squid-2.7.9_3-amd64 failed!

    Installation aborted.Removing package…
    Starting package deletion for squid-2.7.9_3-amd64...done.
    Removing squid components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squid.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    How can I solve this?

    Thank you in advance



  • Try it again?  It's complaining about a bad checksum so maybe oyu had a corrupted download.  Also, squid2 is ancient.  I would use squid3 instead.



  • I´ve tryed with squid, squid2 and 3 more than one time, but it is always the same :/

    Beginning package installation for squid3 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squid3 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/amd64/8/All/squid-3.1.22_1-amd64.pbi ...  (extracting)
    Verifying Checksum...SKIP_ARCHLINES: 61
    Archive checksum: 49117e85b6317518e15e1385d4011e607b7080bdbf99baa0aec51862882730ee
    Saved checksum: b5b5ca566d1119872d0795f5f8a9a0d237a250743b7e02cbc7285e0fdaa77393
    pbi_add: /tmp/apkg_squid-3.1.22_1-amd64.pbi failed checksum, the archive may be corrupt.
    of squid-3.1.22_1-amd64 failed!

    Installation aborted.Removing package…
    Starting package deletion for squid-3.1.22_1-amd64...done.
    Removing squid3 components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squid.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.



  • What version of pfSense?  2.1.x?  It looks old if you're still using squid 3.1.



  • It is 2.1.5…
    How can I do it then?



  • I would upgrade it first to 2.2.3 and then try again.



  • i have same error
    this error apeared after update pfsense from 2.2.2 to 2.2.3 :)
    please letme know if you solve problem
    many thanks


  • Banned

    Are you sure you don't have corrupt incomplete download served by some proxy over and over again? Other than that, as a random idea, if you only see this on 2.2.3, try

    
    mount -o nosync /
    
    

Log in to reply