• I searched CVS trac, couldn't find this issue. Using Beta 2 I am having troubles creating WAN->LAN rules. For example, I am trying to setup my bittorrent port to be Nat'ed to my pc. I created the NAT, created the rule, and the firewall is still denying it. I then tried deleting the NAT and rule and starting over. This time I told the NAt to create the rule. Still nothing. This has been happening to me frequently. I have posted the screenies of the traffic still being blocked even after the rule and nat has been written and applied.  Am I missing something here?









  • Click on the block icon in front of your firewalllog. It will show you what rule caused the block. The only thing I can think of is that your ruleset didn't get loaded. However, in that case you should get an alert about that condition. Edit the rule and save it without changing anything and hit save. Apply the settings and watch your system logs and the Alert scroller. Does something pop up there? Also try deleting the NAT rule and the firewall rule again and let the firewall autocreate the firewall rule. Upgrading to http://pfsense.com/~sullrich/RELENG_1_SNAPSHOT_03-26-2006/ is also recommended before diving down into more debugging.


  • Tried your suggestions. Same thing. Did not work. I had to reboot the firewall before the rule would apply. ???

  • LAYER 8 Moderator

    I've come to similar probs with beta and (nat) rule creation. Sometimes it seems that the filter did not get updated as reported by pfSense. Will check this in the latest snapshot but sometimes it helps to edit a filter rule, save it and hit reload.

    Greets,
    Grey