2.2.3 under vmW with 3 NIC's DOA, Forum kills msg if Captcha not correct



  • This is frustrating.  I typed my message, enter the "correct" captcha information, it claimed it was incorrect and asked me to re-enter it, but erased all of my typing.

    So, VM under vmW 11.0.2; 2 vCPU's, 2GB RAM, no USB or Sound, 3 NICs.
    Installed from 2.2.3 live image.  When it rebooted from hdd, it did not start configuration script as it used to.
    Configured three NIC's since it had only shown two, assigned external as DHCP, two internals as static.
    Manually started GUI and PHP and tried to log in to WebGUI.  Succeeded three out of 20 times.  With each change made in GUI, such as passwd change, GUI was no longer available.  Nothing in system log.

    Re-installed about five times, last time recreating the vhd.

    Am I doing something wrong, or am I missing something?



  • Post worked this time.  Of course I copied text prior to posting.  ;D

    I may have typed the captcha erroneously.  (Not me, I never make mistakes… )



  • Can you describe the Big Picture of what you're trying to do?  Just test pfSense?  Or are you trying to set it up as a real firewall under VMware Workstation?



  • I am comparing PFSense vs OpenSuSE with firewall2.

    I had installed it before, can't remember the version, but say two months ago, but had some difficulty port redirection and the sub-domains in BIND.  (Subsequently found out, PFSense does not ship with Bind but a DNS client only)  ;)  I was trying with the FBSD  community;  (they can get downright nasty, for the smallest suggestion).  Anyway, I've been using OpenSuSE for almost 20 years, so I thought I'd build my own firewall/router.

    So I've determined that OpenSuSE is much slower than PFSense when routing;  and I can't be bothered to figure out how to QOS the Linux kernel.  So I'm trying to re-install PFSense.

    But I've having issues with the new version, which  I didn't have with the prior version.

    Note, I have not installed any VM tools.  And once configured, I will be adding SQUID proxy.

    70tas


  • Rebel Alliance Global Moderator

    why don't you get it working before you add the proxy - so any issues you have will be isolated to a proxy problem and not an underlying configuration issue.  I would start with very basic wan/lan setup then complicate the setup as you move forward.  Pfsense is really click click up and running out of the box type of distro.

    As to pfsense only have a dns client?  It comes built in with dnsmasq a caching dns forwarder or unbound which can run in forwarder or resolver mode.  While its not as feature rich as bind, unless you need a specific feature of bind unbound should be able to handle whatever it is would normally run.  Supports dnssec, is a real resolver and not just forwarder - with the over rides you can create records that you might want to resolver to specific IPs, you can also you a domain over ride to point to delegated ns for specific domains, etc.

    And if you really really want you can install bind on pfsense.

    As to port forwarding in pfsense - this has never really been an issue and I would say 99.9% of the problems with are PEBKAC..

    How exactly are you installing it under vmware workstation, these interfaces you give to pfsense - are they bridged in workstation from your physical interfaces, nat interfaces in workstation?  How is the layer one connections to your box your running workstation on setup?  A drawing of your network and placement of this workstation running box your trying to put pfsense on is worth a 1000 words

    Is this box running workstation your normal workstation or is the hardware going to be dedicated to running vms?  If so would prob pick something other than workstation, esxi, hyper-v, xen, etc.  Have you validated that your version of workstation supports freebsd 10.1?  For example esxi did not add until 5.5u2 so if your running on a hypervisor that does not really support your OS on your vm you can run into all kinds of unexpected issues.



  • I have not added the proxy.  I am using a standard install.

    However, I have figured out the issue, for now, anyway.

    When I configured before, I did an auto install with vmW.  Before powering on, I assigned the .iso, I made sure that FreeBSD x64 was set and so on.  vmW installed the NIC's as E1000's, as it should as they are the highest performing.  The I booted up and hit "I" to install to the hard disc.  When it rebooted, the system did not ask for a configuration.

    I tried it again, after deleting the entire vm folder.  The only difference, is that this time, I checked the "I will install an Operating System later" checkbox in the vmW configurator.  I booted as before, and pressed "I" to install.  The configurator started after the machine came up, but it showed me three interfaces, and em0, an lo0 and and lo1.  I shut down and checked my .vmx (config) file, and sure enough, the first Nic, Ethernet0 had the "ethernet0.virtualDev = "e1000"" set.  Ethernet1 and Ethernet2 did not, meaning they were being setup as vmxnet devices (lower performance).  So I added the entries in the appropriate places for "ethernet1.virtualDev = "e1000"", and "ethernet2.virtualDev = "e1000"".

    When I rebooted, the configuration did not start.

    I powered off again, turned the em2/Ethernet2 device off in vmW.  Rebooted, config started up.  Don't know why, but I think when I installed the prior version, I only installed two NICs to start with.

    I was able to change the password and set the WAN to DHCP, and commit, and the WebGUI came back.

    So I would imagine this may have something to do with the open source VM drivers.  I have been having trouble with those on FBSD, PCBSD, and on Fedora 22.

    I will continue configuring and report back to this thread.  I need to add my DNS and DHCP server and move my scope and zone over from OpenSuSE.  I will enable em2 via the WebGUI and see what happens.

    Later and thanks.



  • Well, I have not figured it out.  I have tried all kind of things, assigning, offlining and onlining NICs, restarting services.  WebGUI fails a few minutes after logging in, and will not respond again until a reboot.  I have tried looking in /var/logs but do not see anything which may help.

    Anyone have any ideas?


  • Rebel Alliance Global Moderator

    You could give your vm a hundred nics…  What are they connected too??

    You want to give your vm 3 nics.. Does your workstation have 3 physical nics?  Should be at min 2, one for your WAN and then another to your lan..

    Are you running on workstation on linux...  BTW current version is 11.1.2, if your on 11.0.2 your bit OLD..

    I just downloaded a trial and and took all of 2 minutes to setup..

    What port is your vmware workstation server listening on - by default its 443, what port are you trying to hit your pfsense webgui on?

    So the host only network is 192.168.144 on my setup, my normal lan segment is 192.168.9/24 -- the installed defaulted to 192.168.1 -- changed this to be on the workstation host only network vmnet1 which 192.168.144 and bing bang zoom..

    So again I will ask how is your workstation network stuff setup.. Don't really care what emulator you used.. be it e1000 or vmx3

    I used bridged interface that is connected to my network for WAN em0 for pfsense vm, I used the host only network for the LAN le0 in pfsense - bing bang boom clickity clickity up and running!!