Recovering from 109% full disk situation



  • I left ntopng historical data turned on for too long and not surprisingly it filled up the root file system.

    It sure seems weird to report 109% of capacity used.  This is on a Hyper-V virtual machine, here's a snapshot I grabbed before recovering:

    [2.2.2-RELEASE][root@pfSense.trumpetinc.local]/var/log: df -hi
    Filesystem      Size    Used   Avail Capacity iused ifree %iused  Mounted on
    /dev/ada0s1a    3.9G    3.9G   -316M   109%    290k  271k   52%   /
    devfs           1.0K    1.0K      0B   100%       0     0  100%   /dev
    /dev/md0        3.4M    108K    3.0M     3%      34   988    3%   /var/run
    devfs           1.0K    1.0K      0B   100%       0     0  100%   /var/dhcpd/dev
    [2.2.2-RELEASE][root@pfSense.trumpetinc.local]/var/log:
    

    Is this peculiar to FreeBSD and/or Hyper-V … or am I just not reading this correctly?

    I tried uninstalling the ntopng package - but that, understandably failed. Using ssh I tried deleting one of the larger folders under the /var/db/ntopng (/var/db/ntopng/0) - it freed up around 500MB, but the firewall still would not pass traffic. Restoring back several days seemed to fix the problem.



  • There is reserved space, so usage can go over 100%.

    After deleting ntopng's files, a filter reload (or reboot) likely would have brought things back to a sane state.



  • Thanks for enlightening me on the 109% full.

    We did perform a reboot after freeing some disk, but it did not seem to help. I restored Sunday and Saturday - they too did not work. Restoring Friday night let  things get back to norma.