Target group: in-addr



  • s.a pfsense 2.1.5 kullanıyorum şöyle bir sorun yaşıyorum web servisler vs. siteler www.xxxx.com şeklinde değilde direk ip olarak hizmet veriyor örneğin 78.50.1.1 gibi ip adresi şeklinde hizmet veren servislere izin veremiyorum

    Client address: 10.0.0.10
    Client group: default
    Target group: in-addr
    URL: http://78.50.1.1/

    Target group: in-addr  diyor ve aşamadım bunu yardımcı olabilirmisiniz.

    proxy server > Bypass proxy for these source IPs> tanımladım ama yine sorun çözülmedi.



  • Merhaba,

    Hangi paketleri kurdunuz. Ör: SquidGuard kurulu mu?

    SGTR



  • @SGTR:

    Merhaba,

    Hangi paketleri kurdunuz. Ör: SquidGuard kurulu mu?

    SGTR

    evet kurulu

    squid
    ve
    squidGuard



  • bu sorunla ilgili kimsenin yapabileceği birşey yokmu ?



  • @Denge:

    bu sorunla ilgili kimsenin yapabileceği birşey yokmu ?

    Bende de benzer sorun vardı.

    usr/local/etc/squidGuard/squidGuard.conf dosyasının içeriği aşağıdakine benzer olmalı.

    Sondaki acl satırı ve sonrasında in-addr vardı.Sildim ve aşağıdaki gibi düzelttim.

    Config dosyasını aşağıdaki kodla değiştirdim.
    Proxy filter ayarlarını tekrar save'ledim ve oldu.

    #/usr/local/etc/squidGuard/squidGuard.conf
    # ============================================================
    # SquidGuard configuration file
    # This file generated automaticly with SquidGuard configurator
    # (C)2006 Serg Dvoriancev
    # email: dv_serg@mail.ru
    # ============================================================
    
    logdir /var/squidGuard/log
    dbhome /var/db/squidGuard
    
    # 
    dest blk_BL_adv {
    	domainlist blk_BL_adv/domains
    	urllist blk_BL_adv/urls
            redirect http://PFSENSE-IP:80/sgerror.php?url=blank_img
    }
    
    # 
    dest blk_BL_aggressive {
    	domainlist blk_BL_aggressive/domains
    	urllist blk_BL_aggressive/urls
    }
    
    # 
    dest blk_BL_alcohol {
    	domainlist blk_BL_alcohol/domains
    	urllist blk_BL_alcohol/urls
    }
    
    #Several "dest" options....  
    
    # 
    rew safesearch {
    	s@(google\..*/search?.*q=.*)@\1\&safe=active@i
    	s@(google\..*/images.*q=.*)@\1\&safe=active@i
    	s@(google\..*/groups.*q=.*)@\1\&safe=active@i
    	s@(google\..*/news.*q=.*)@\1\&safe=active@i
    	s@(yandex\..*/yandsearch?.*text=.*)@\1\&fyandex=1@i
    	s@(search\.yahoo\..*/search.*p=.*)@\1\&vm=r&v=1@i
    	s@(search\.live\..*/.*q=.*)@\1\&adlt=strict@i
    	s@(search\.msn\..*/.*q=.*)@\1\&adlt=strict@i
    	s@(\.bing\..*/.*q=.*)@\1\&adlt=strict@i
    }
    
    # 
    acl  {
    	# 
    	default  {
    		pass all
    		redirect http://PFSENSE-IP:80/sgerror.php?url=403%20&a=%a&n=%n&i=%i&s=%s&t=%t&u=%u
    	}
    }
    


  • @gazili84:

    @Denge:

    bu sorunla ilgili kimsenin yapabileceği birşey yokmu ?

    Bende de benzer sorun vardı.

    usr/local/etc/squidGuard/squidGuard.conf dosyasının içeriği aşağıdakine benzer olmalı.

    Sondaki acl satırı ve sonrasında in-addr vardı.Sildim ve aşağıdaki gibi düzelttim.

    Config dosyasını aşağıdaki kodla değiştirdim.
    Proxy filter ayarlarını tekrar save'ledim ve oldu.

    #/usr/local/etc/squidGuard/squidGuard.conf
    # ============================================================
    # SquidGuard configuration file
    # This file generated automaticly with SquidGuard configurator
    # (C)2006 Serg Dvoriancev
    # email: dv_serg@mail.ru
    # ============================================================
    
    logdir /var/squidGuard/log
    dbhome /var/db/squidGuard
    
    # 
    dest blk_BL_adv {
    	domainlist blk_BL_adv/domains
    	urllist blk_BL_adv/urls
            redirect http://PFSENSE-IP:80/sgerror.php?url=blank_img
    }
    
    # 
    dest blk_BL_aggressive {
    	domainlist blk_BL_aggressive/domains
    	urllist blk_BL_aggressive/urls
    }
    
    # 
    dest blk_BL_alcohol {
    	domainlist blk_BL_alcohol/domains
    	urllist blk_BL_alcohol/urls
    }
    
    #Several "dest" options....  
    
    # 
    rew safesearch {
    	s@(google\..*/search?.*q=.*)@\1\&safe=active@i
    	s@(google\..*/images.*q=.*)@\1\&safe=active@i
    	s@(google\..*/groups.*q=.*)@\1\&safe=active@i
    	s@(google\..*/news.*q=.*)@\1\&safe=active@i
    	s@(yandex\..*/yandsearch?.*text=.*)@\1\&fyandex=1@i
    	s@(search\.yahoo\..*/search.*p=.*)@\1\&vm=r&v=1@i
    	s@(search\.live\..*/.*q=.*)@\1\&adlt=strict@i
    	s@(search\.msn\..*/.*q=.*)@\1\&adlt=strict@i
    	s@(\.bing\..*/.*q=.*)@\1\&adlt=strict@i
    }
    
    # 
    acl  {
    	# 
    	default  {
    		pass all
    		redirect http://PFSENSE-IP:80/sgerror.php?url=403%20&a=%a&n=%n&i=%i&s=%s&t=%t&u=%u
    	}
    }
    

    Öncelikle ilgine teşekkür ederim

    Sanırım 2.1.5 versiyonunda dosya yolu /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf bu şekilde değiştirilmiş.
    sonrasıda bahsettiğin düzenlemeleri yapıyorum fakat squidGuard da tanımlı olan ayarları kaydedip appy dediğimde default ayarlarını baştan yazıyor eski haline dönüyor.



  • arkadaşlar sorunu çözdüm aslında sorun bile değilmiş gözümün önündeymiş.

    Proxy filter SquidGuard: Common Access Control List (ACL)

    altında

    Do not allow IP-Addresses in URL işaretli ise işareti kaldırın save ve apply yaptığınızda sonrun kalmıyor.


Log in to reply