Pfsens mit squid klappt nicht



  • Hi Leute,

    Mein Ansinnen ist folgendes:

    Ich habe eine bestehende Infrastruktur mit einer funktionierende pfsense mit nat und vpn usw. nun will ich ein Gästenetz einrichten das hinter meinem bestehendem Netz läuft.
    Das klappt soweit auch - ich hab die pfsense laufen und auch eine bestehende Internetverbindung mit dhcp das würde soweit auch klappen. nun will ich aber einen Contentfilter einrichten mit squid und squidguard - das an sich sollte kein Problem sein und ich habe auch schon einige Tutorials gesehen - sollte alles kein Problem sein allerdings scheitere ich daran, dass sobald ich den Transparenten Proxy aktiviere keine Seite mehr erreiche. Was könnte hier mein Fehler sein ?



  • Da meine Kristallkugel gerade in Reparatur ist, kann ich nur Raten…

    Hast du den Haken "Allow users on interface" aktiviert, sind die passenden Interfaces ausgewählt, auf die Squid reagieren soll ?

    lg
    Rubinho



  • Welche Informationen hättest du gerne um nicht die Kristallkugel zu befragen :)

    Mir ist schon klar das es jetzt nicht die Lösung gibt anhand der Infos, ich dachte aber, dass es so eine reihe von Grundfehlern gibt die gehäuft passieren.



  • Ich schiesse jetzt auch einfach mal ins blaue und sag:

    hast Du den Squid-Port 3128 per Firewall-Regel fürs genutzte Interface/LAN-NET und fürs TCP-Protkoll freigegeben?

    Und um in Deinem eigenen Fragestil zu bleiben: Hast Du alle sonstigen Einstellungen richtig durchgeführt? :-)



  • Was könnte hier mein Fehler sein ?

    Wenn der Proxy transparent sein soll muss man die "interfaces bridgen".

    nun will ich ein Gästenetz einrichten das hinter meinem bestehendem Netz läuft.

    Und für wen möchtest Du das tun? WLAN oder LAN Gäste, mit Radius Server oder Captive Portal
    in VLANs oder nicht, nur für WLAN Gäste oder auch für Deine WLAN Geräte?

    Schreib mal bitte ruhig ein bisschen mehr dazu, sonst raten wir hier alle im freien Fall.