Vmware workstation 11 Pfsense unable to ping either LAN or WAN



  • HI, new to these forums but i hope someone can help.

    My setup is as follows, i have a pfsense set up as Virtual machine in VMware workstation 11. The WAN connection is bridged through to my wifi adapter and my LAN is bridged through to a ethernet port the Lan port is connected a physical  switch.

    The problem is that i can neither ping to the WAN or LAN side or access the GUI.
    LAN ip 192.168.1.253
    Windows 7 virtual 192.168.1.20 subnet for both /24
    These are both connected in to the bridged switch VMnet2 i can ping from my switch and back, i can put another computer into that network and can ping.
    Wan ip 192.168.2.111/24
    Host machine wifi 192.168.2.101/24

    I am unable to ping either interface i have tried to reset to factory default, also tried changing to a host only network nothing seems to work ?

    Can anyone help ?

    Edit using pfsense 2.2.1


  • LAYER 8 Global Moderator

    vmnet2 is not bridge switch by default..

    So why would you be using 2.2.1 curious.. 2.2.3 has been out for a while..

    where exactly are you trying to ping from?  So your saying you can not ping pfsense lan that is bridge to same network your PC physical nic is bridged too?  Yeah then never going to do anything..  You have a problem with workstation or bridge into your nic in workstation.  Or when you changed pfsense lan IP from default it didn't take?  Did you reboot pfsense vm after you changed its lan IP?  Or you reversed the vm nics and are connected to the wrong things..

    If you say you can ping other vms on that same vmnet2 from your pc, I would think you reversed the nics in pfsense - check the mac of the interface in workstation you have on pfsense.  See attached, and then check in pfsense what mac is its wan and which its lan, etc.




  • I am using that as its the copy i have because my internet is restricted here.

    I have set up 2 bridges VMnet 0 which is bridged to my wifi.
    VMnet 2 Which is bridged to a ethernet port

    I have a windows 7 virtual machine on vmnet 2 same as pfsense that i am trying to get connectivity to.

    I have two bridges connected one to the to  wifi for internet and one to a ethernet port. i have tried changing the interfaces on the virtual still cant connect
    LAN ip has taken

    Checked mac address they are correct




  • update i can ping from pfsense to my wifi ip but not back



  • i also know that its not a vmware problem because i can access freenas which a virtual machine with the same settings bar the ip  address

    Also now updated to 2.2.3


  • LAYER 8 Global Moderator

    out the box your not going to be able to ping pfsense wan, you would have to create a firewall rule to ping the wan.

    Well it sure is not pfsense because it took me all of 3 minutes to install it on workstation 11 and have it working.

    "I have a windows 7 virtual machine on vmnet 2 same as pfsense that i am trying to get connectivity to."

    Where are you trying to get connectivity from?  Pfsense wan??  Well you would have to port forward, out of the box pfsense Blocks all access inbound from the WAN..  On your vm connected to the lan side can you ping pfsense lan IP?  Can you access the gui from vm connected to pfsense lan?

    Did you install the tools - I know tools on esxi breaks stuff, and no need to use them – you can just install the openvmtools package.



Log in to reply