Interface bridge WAN>LAN2



  • Hello,

    From my ISP I get 15 external IP addresses to use. I want to create an interface without NAT so I decided to use an interface bridge between WAN and LAN2.

    My LAN2 isn't working, when I set a static external IP address on the machine connected to LAN2 I can't access the internet. I have created a Firewall rule on the Interface allowing from any to any, protocol's any. When I unplug the WAN Ethernet cable from the Pfsense and plug that into the the static IP configured machine it is working.
    Can anyone explain me why it isn't working?


  • Rebel Alliance Global Moderator

    Because your doing it wrong.. Why would you think you would ever want to bridge your wan to your lan2 ??

    Create virtual IPs on your wan and port forward or 1:1 nat these to the machines behind pfsense on their rfc1918 address.  Unless this network is routed to you - that is how you would do it.



  • @johnpoz:

    Because your doing it wrong.. Why would you think you would ever want to bridge your wan to your lan2 ??

    Create virtual IPs on your wan and port forward or 1:1 nat these to the machines behind pfsense on their rfc1918 address.  Unless this network is routed to you - that is how you would do it.

    Heey thank you for your reply!

    I want to connect my server directly to the internet. On my server I want to set a static IP instead of natting and a rfc1918 address.



  • This is what I have done for bridging the interfaces

    1. I created a new VLAN 700
    2. I created a new interface with no ip configuration
    3. I have created a bridge interface between WAN and VLAN 700 (lan2)
    4. I have created a Firewall rule allowing any to any protocol's any for the interface VLAN 700
    5. I have create a Firewall rule on the bridge interface allowing any to any

    Thanks in advance,


  • Rebel Alliance Global Moderator

    "I want to connect my server directly to the internet."

    I never understand why??  Why would you want to do that?  Just forward the ports you want, what does it get you having public IP on your server directly??

    But if that is what you want then follow the instructions for setting up pfsense in transparent mode.

    Why don't you just get your addresses routed to you!!  This is how is would normally be done.. Then you don't have to dick with bridges and or aliases, etc.  You can put your public netblock behind your firewall.



  • @johnpoz:

    "I want to connect my server directly to the internet."

    I never understand why??  Why would you want to do that?  Just forward the ports you want, what does it get you having public IP on your server directly??

    But if that is what you want then follow the instructions for setting up pfsense in transparent mode.

    Why don't you just get your addresses routed to you!!  This is how is would normally be done.. Then you don't have to dick with bridges and or aliases, etc.  You can put your public netblock behind your firewall.

    Hi Johnpoz,

    It is because customers are using their own router/server to connect directly to the internet. I need to assign the public IP address directly to the hosts. And I also have some customers, they don't have a router so I use port forward there on pfsense.


  • Rebel Alliance Global Moderator

    "t is because customers are using their own router/server to connect directly to the internet"

    So you want to play at being an ISP or DC…  Then have the networks you own routed to you correctly..



  • I want to connect my server directly to the internet. On my server I want to set a static IP instead of natting and a rfc1918 address.

    In normal this would be the worst case for an admin!

    But if you are an ISP or WISP or Datacenter you should be running other routers that are
    heavy enough to route this traffic.



  • Hi Thanks for reply,

    I must be doing something wrong. When I connect a pc at a bridged interface I can't connect to the ethernet. I tested it a lab environment no problems at all. (maybe because I'm using RFC 1918 as WAN).

    When I do this in production environment, I can't connect the internet. I have checked system tunnables to make sure there is no filter. I have created firewall rules to make sure it can pass, no luck!
    Is there something that I need to change with NAT? Important to know is that there are other VLAN's that are using pfsense as router.


  • Netgate

    As has been stated get the public subnet ROUTED to your WAN interface address.  As far as the bridge goes, you'd be better off just plugging them into an outside switch.



  • I want to assign a public IP directly to the host via Pfsense for traffic shaping and external ip management


  • Banned

    When you bridge the damned thing, you need the upstream GW set on the server behind the bridge. Not pfSense! For the third time here, get a routed subnet.



  • @doktornotor:

    When you bridge the damned thing, you need the upstream GW set on the server behind the bridge. Not pfSense! For the third time here, get a routed subnet.

    Hi Thanks! What do you mean by a routed subnet?
    I have set a static ip on the server behind the bridge but not working….
    I have only configured the WAN IP, the bridge and bridged interface not configured.


  • Banned

    I mean you should have /30 for your WAN and /2x for whatever behind that. Talk to your ISP.