No gateway assigned on Win8 client



  • OVPN worked fine with version 2.1.5, but since new 2.2.3 clean install on same box, I can't browse the LAN from the same client machine that worked before.  In setting up ovpn, I used the wizard and followed the documentation to create the pfsense server config, and used the ovpn client export utility to re-install on my Win8 64bit machine.  I can connect to the vpn just fine, and I can access the pfsense gui over the vpn connection.  What I can't do though is browse the lan.

    After some research, it seems the problem stems from the fact that when the ovpn connection is made, an interface is created in Win8 which is tagged as "Public".  In the connection's details, I can see that everything looks fine except that there is no default gateway assigned - it's just blank.  Apparently the interface is assigned as public because there is no gateway.  How can I fix this?


  • LAYER 8 Global Moderator

    why do you think your vpn connection would have a gateway?

    Ethernet adapter vpn:

    Connection-specific DNS Suffix  . : local.lan
      Description . . . . . . . . . . . : TAP-Windows Adapter V9
      Physical Address. . . . . . . . . : 00-FF-5A-2F-7E-EA
      DHCP Enabled. . . . . . . . . . . : Yes
      Autoconfiguration Enabled . . . . : Yes
      IPv4 Address. . . . . . . . . . . : 10.0.8.6(Preferred)
      Subnet Mask . . . . . . . . . . . : 255.255.255.252
      Lease Obtained. . . . . . . . . . : Friday, July 17, 2015 9:40:59 AM
      Lease Expires . . . . . . . . . . : Saturday, July 16, 2016 9:40:59 AM
      Default Gateway . . . . . . . . . :
      DHCP Server . . . . . . . . . . . : 10.0.8.5
      DNS Servers . . . . . . . . . . . : 192.168.9.253
      NetBIOS over Tcpip. . . . . . . . : Enabled

    What IP are you accessing the pfsense gui with?

    Are you trying to route all traffic through the vpn tunnel, or just want to access networks on the other side of the vpn?  You should be seeing routes for the networks on other end of the tunnel..

    example

    route print

    192.168.2.0    255.255.255.0        10.0.8.5        10.0.8.6    20
    192.168.3.0    255.255.255.0        10.0.8.5        10.0.8.6    20
    192.168.9.0    255.255.255.0        10.0.8.5        10.0.8.6    20

    Those are networks behind my vpn that I want to get to..

    C:>net view \192.168.9.8
    Shared resources at \192.168.9.8

    Share name  Type  Used as  Comment

    –-----------------------------------------------------------------------------
    Media      Disk
    Molly      Disk
    Music      Disk
    The command completed successfully.

    What do you mean by "browse" the lan are you wanting it to show up in you network neighbor hood??


  • Banned

    Really up to the user what firewall profile they assign to new networks. Cannot see how's that related to pfSense, at all…



  • perhaps the previous OVPN server config was a bridge with lan (TAP) and now you are running a routed tunnel using TUN ?



  • I can't change the interface type to private, and I can't enable sharing on the interface (unless I enable it on all public networks), so I can't browse the lan.  In win8.1 it seems i can only change the network type for hardware interfaces.  I read somewhere that win8.1 sets interfaces without a gateway to public, but maybe that's wrong.  If that's not it, then what?  Under 2.1.5 it all worked perfectly.  I've done everything by the book here, so to speak, what am I missing?


  • Banned


  • LAYER 8 Global Moderator

    Dude WTF does public vs private or domain have to do with it??  That is just setting your firewall rules that would be inbound rules to that box, not outbound.

    I am on 2.2.3 and it works perfectly as well - a vpn interface does NOT get a GATEWAY!!!  its a TUNNEL!!!

    Connect to your vpn, post up your route print output and your ipconfig /all output  and what IP you trying to get too?


Log in to reply